summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--zfs.install2
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cc2a5fe6331..495ce8286dea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Jan 18 23:54:23 UTC 2018
pkgbase = zfs-linux-hardened
- pkgver = 0.7.5_4.14.14.a.1
+ pkgver = 0.7.6_4.14.17.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.14.14.a-1
+ makedepends = linux-hardened-headers=4.14.17.a-1
makedepends = spl-linux-hardened-headers
depends = kmod
depends = spl-linux-hardened
- depends = zfs-utils-common=0.7.5
- depends = linux-hardened=4.14.14.a-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz
- sha256sums = SKIP
+ depends = zfs-utils-common=0.7.6
+ depends = linux-hardened=4.14.17.a-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz
+ sha256sums = 1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d
pkgname = zfs-linux-hardened
pkgdesc = Kernel modules for the Zettabyte File System.
diff --git a/PKGBUILD b/PKGBUILD
index 2e4ab7eb5c4c..47af5dd1daa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,24 +18,24 @@
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.5_4.14.14.a.1
+pkgver=0.7.6_4.14.17.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.14.a-1" "spl-linux-hardened-headers")
+makedepends=("linux-hardened-headers=4.14.17.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz")
-sha256sums=("SKIP")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
+sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.5" "linux-hardened=4.14.14.a-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.6" "linux-hardened=4.14.17.a-1")
build() {
- cd "${srcdir}/zfs-0.7.5"
+ cd "${srcdir}/zfs-0.7.6"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.14-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.14-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.17-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.17-1-hardened/build
make
}
@@ -45,7 +45,7 @@ package_zfs-linux-hardened() {
provides=("zfs")
groups=("archzfs-linux-hardened")
conflicts=('zfs-linux-hardened-git')
- cd "${srcdir}/zfs-0.7.5"
+ cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -56,9 +56,9 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.5"
+ cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.14-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.17-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index c0031253fc95..9429d0aefb1a 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.14-1-hardened
+ depmod -a 4.14.17-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'