summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e40995cc88ae..79cb2e8a647b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Oct 6 17:52:31 UTC 2017
+# Thu Oct 12 18:41:10 UTC 2017
pkgbase = zfs-linux-hardened-git
- pkgver = 0.7.0.r103.ga0430cc5a.4.13.5.a.1
+ pkgver = 0.7.0.r118.ge0922b042.4.13.6.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.13.5.a-1
+ makedepends = linux-hardened-headers=4.13.6.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
- depends = zfs-utils-common-git>=0.7.0.r103.ga0430cc5a
- depends = linux-hardened=4.13.5.a-1
+ depends = zfs-utils-common-git>=0.7.0.r118.ge0922b042
+ depends = linux-hardened=4.13.6.a-1
source = git+https://github.com/zfsonlinux/zfs.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0c84f08b4f2d..61321d55c6ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,19 +18,19 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=0.7.0.r103.ga0430cc5a.4.13.5.a.1
+pkgver=0.7.0.r118.ge0922b042.4.13.6.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.13.5.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.13.6.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0.r103.ga0430cc5a" "linux-hardened=4.13.5.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0.r118.ge0922b042" "linux-hardened=4.13.6.a-1")
pkgver() {
cd "${srcdir}/zfs"
- echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.13.5.a.1
+ echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.13.6.a.1
}
build() {
@@ -39,8 +39,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.2 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.13.5-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.13.5-1-hardened/build
+ --with-linux=/usr/lib/modules/4.13.6-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.13.6-1-hardened/build
make
}
@@ -65,5 +65,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.5-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.6-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 41fe0aceb927..162139caea1b 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.13.5-1-hardened
+ depmod -a 4.13.6-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'