summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--zfs.install2
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18836037dad6..29436d5e6e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Aug 2 02:49:48 UTC 2017
+# Thu Aug 10 04:55:28 UTC 2017
pkgbase = zfs-linux-hardened-git
- pkgver = 0.7.0_r8_gaf0f84288_4.12.4.a_1
- pkgrel = 2
+ pkgver = 0.7.0_r19_g46364cb2f_4.12.5.a_1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.12.4.a-1
+ makedepends = linux-hardened-headers=4.12.5.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
- depends = zfs-utils-common-git>=0.7.0_r8_gaf0f84288
- depends = linux-hardened=4.12.4.a-1
+ depends = zfs-utils-common-git>=0.7.0_r19_g46364cb2f
+ depends = linux-hardened=4.12.5.a-1
source = git+https://github.com/zfsonlinux/zfs.git
sha256sums = SKIP
@@ -26,7 +26,6 @@ pkgname = zfs-linux-hardened-git
pkgname = zfs-linux-hardened-git-headers
pkgdesc = Kernel headers for the Zettabyte File System.
conflicts = zfs-archiso-linux-headers
- conflicts = zfs-utils-common-git-headers
conflicts = zfs-linux-hardened-headers
conflicts = zfs-linux-lts-headers
conflicts = zfs-linux-lts-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 5f127d08361f..c1c6f82f801d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,24 +17,24 @@
#
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=0.7.0_r8_gaf0f84288_4.12.4.a_1
-pkgrel=2
-makedepends=("linux-hardened-headers=4.12.4.a-1" "git" "spl-linux-hardened-git-headers")
+pkgver=0.7.0_r19_g46364cb2f_4.12.5.a_1
+pkgrel=1
+makedepends=("linux-hardened-headers=4.12.5.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0_r8_gaf0f84288" "linux-hardened=4.12.4.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0_r19_g46364cb2f" "linux-hardened=4.12.5.a-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.4-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.4-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.12.5-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.5-1-hardened/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-hardened-git() {
package_zfs-linux-hardened-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-utils-common-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.4-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.5-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index bdc10c64bdcf..4c3f092e0260 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.12.4-1-hardened
+ depmod -a 4.12.5-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'