summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68e60b35a8d2..fc55428b1c49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Thu Aug 10 04:42:07 UTC 2017
+# Sun Aug 13 20:56:47 UTC 2017
pkgbase = zfs-linux-lts-git
- pkgver = 0.7.0_r19_g46364cb2f_4.9.41_1
+ pkgver = 0.7.0.r25.g376994828.4.9.42.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-lts-headers=4.9.41-1
+ makedepends = linux-lts-headers=4.9.42-1
makedepends = libelf
makedepends = git
makedepends = spl-linux-lts-git-headers
depends = kmod
depends = spl-linux-lts-git
- depends = zfs-utils-common-git>=0.7.0_r19_g46364cb2f
- depends = linux-lts=4.9.41-1
+ depends = zfs-utils-common-git>=0.7.0.r25.g376994828
+ depends = linux-lts=4.9.42-1
source = git+https://github.com/zfsonlinux/zfs.git
sha256sums = SKIP
@@ -32,4 +32,6 @@ pkgname = zfs-linux-lts-git-headers
conflicts = zfs-linux-lts-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-zen-headers
+ conflicts = zfs-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 31fa1c3c732e..f7eb07c0c278 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
#
pkgbase="zfs-linux-lts-git"
pkgname=("zfs-linux-lts-git" "zfs-linux-lts-git-headers")
-pkgver=0.7.0_r19_g46364cb2f_4.9.41_1
+pkgver=0.7.0.r25.g376994828.4.9.42.1
pkgrel=1
-makedepends=("linux-lts-headers=4.9.41-1" "libelf" "git" "spl-linux-lts-git-headers")
+makedepends=("linux-lts-headers=4.9.42-1" "libelf" "git" "spl-linux-lts-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-lts-git" "zfs-utils-common-git>=0.7.0_r19_g46364cb2f" "linux-lts=4.9.41-1")
+depends=("kmod" "spl-linux-lts-git" "zfs-utils-common-git>=0.7.0.r25.g376994828" "linux-lts=4.9.42-1")
build() {
cd "${srcdir}/zfs"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.9.41-1-lts/build \
- --with-linux-obj=/usr/lib/modules/4.9.41-1-lts/build
+ --with-linux=/usr/lib/modules/4.9.42-1-lts/build \
+ --with-linux-obj=/usr/lib/modules/4.9.42-1-lts/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-lts-git() {
package_zfs-linux-lts-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.9.41-1-lts/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.9.42-1-lts/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index f2d4a35c4b63..1ebaff1a9fe1 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.9.41-1-lts
+ depmod -a 4.9.42-1-lts
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'