summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD62
-rw-r--r--zfs.install22
4 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c7b90a03a4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Sun Aug 13 23:38:06 UTC 2017
+pkgbase = zfs-linux-zen-git
+ pkgver = 0.7.0.r25.g376994828.4.12.5.1
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ arch = x86_64
+ license = CDDL
+ makedepends = linux-zen-headers=4.12.5-1
+ makedepends = git
+ makedepends = spl-linux-zen-git-headers
+ depends = kmod
+ depends = spl-linux-zen-git
+ depends = zfs-utils-common-git
+ depends = linux-zen=4.12.5-1
+ source = git+https://github.com/zfsonlinux/zfs.git
+ sha256sums = SKIP
+
+pkgname = zfs-linux-zen-git
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ install = zfs.install
+ groups = archzfs-linux-zen-git
+ provides = zfs
+ conflicts = zfs-linux-zen
+
+pkgname = zfs-linux-zen-git-headers
+ pkgdesc = Kernel headers for the Zettabyte File System.
+ conflicts = zfs-archiso-linux-headers
+ conflicts = zfs-linux-hardened-headers
+ conflicts = zfs-linux-hardened-git-headers
+ conflicts = zfs-linux-lts-headers
+ conflicts = zfs-linux-lts-git-headers
+ conflicts = zfs-linux-headers
+ conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-zen-headers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b18b49395bde
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log
+zfs/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ea4139aee15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-zen packages will only work with the default linux-zen package! To have a single PKGBUILD target many
+# kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgbase="zfs-linux-zen-git"
+pkgname=("zfs-linux-zen-git" "zfs-linux-zen-git-headers")
+pkgver=0.7.0.r25.g376994828.4.12.5.1
+pkgrel=1
+makedepends=("linux-zen-headers=4.12.5-1" "git" "spl-linux-zen-git-headers")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("git+https://github.com/zfsonlinux/zfs.git")
+sha256sums=("SKIP")
+license=("CDDL")
+depends=("kmod" "spl-linux-zen-git" "zfs-utils-common-git" "linux-zen=4.12.5-1")
+
+build() {
+ cd "${srcdir}/zfs"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
+ --datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
+ --libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.12.5-1-zen/build \
+ --with-linux-obj=/usr/lib/modules/4.12.5-1-zen/build
+ make
+}
+
+package_zfs-linux-zen-git() {
+ pkgdesc="Kernel modules for the Zettabyte File System."
+ install=zfs.install
+ provides=("zfs")
+ groups=("archzfs-linux-zen-git")
+ conflicts=('zfs-linux-zen')
+ cd "${srcdir}/zfs"
+ make DESTDIR="${pkgdir}" install
+ cp -r "${pkgdir}"/{lib,usr}
+ rm -r "${pkgdir}"/lib
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_zfs-linux-zen-git-headers() {
+ pkgdesc="Kernel headers for the Zettabyte File System."
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' )
+ cd "${srcdir}/zfs"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.5-1-zen/Module.symvers
+}
diff --git a/zfs.install b/zfs.install
new file mode 100644
index 000000000000..b1e00d1c1cea
--- /dev/null
+++ b/zfs.install
@@ -0,0 +1,22 @@
+post_install() {
+ check_initramfs
+}
+
+post_remove() {
+ check_initramfs 'remove'
+}
+
+post_upgrade() {
+ check_initramfs
+}
+
+check_initramfs() {
+ echo ">>> Updating ZFS module dependencies"
+ depmod -a 4.12.5-1-zen
+ MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
+ if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
+ echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '>>> "hooks" list and then regenerate the initial ramdisk.'
+ fi
+}