summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--zfs.install2
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8afbe08504db..3e77201f883e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Dec 3 23:39:05 UTC 2017
+# Wed Dec 13 20:42:07 UTC 2017
pkgbase = zfs-linux-zen-git
- pkgver = 0.7.0.r200.gd4677269f.4.14.3.1
- pkgrel = 3
+ pkgver = 2017.12.08.r3208.4e9b15696.4.14.5.1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-zen-headers=4.14.3-1
+ makedepends = linux-zen-headers=4.14.5-1
makedepends = git
makedepends = spl-linux-zen-git-headers
depends = kmod
depends = spl-linux-zen-git
- depends = zfs-utils-common-git>=0.7.0.r200.gd4677269f
- depends = linux-zen=4.14.3-1
- source = git+https://github.com/zfsonlinux/zfs.git
+ depends = zfs-utils-common-git=2017.12.08.r3208.4e9b15696
+ depends = linux-zen=4.14.5-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=4e9b156960562373e005798575a3fbc6d66e32ff
sha256sums = SKIP
pkgname = zfs-linux-zen-git
@@ -22,6 +22,7 @@ pkgname = zfs-linux-zen-git
groups = archzfs-linux-zen-git
provides = zfs
conflicts = zfs-linux-zen
+ replaces = zfs-git
pkgname = zfs-linux-zen-git-headers
pkgdesc = Kernel headers for the Zettabyte File System.
@@ -32,5 +33,7 @@ pkgname = zfs-linux-zen-git-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-vfio-headers
+ conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index b561224af53f..03adc5812a3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,29 +17,24 @@
pkgbase="zfs-linux-zen-git"
pkgname=("zfs-linux-zen-git" "zfs-linux-zen-git-headers")
-pkgver=0.7.0.r200.gd4677269f.4.14.3.1
-pkgrel=3
-makedepends=("linux-zen-headers=4.14.3-1" "git" "spl-linux-zen-git-headers")
+pkgver=2017.12.08.r3208.4e9b15696.4.14.5.1
+pkgrel=1
+makedepends=("linux-zen-headers=4.14.5-1" "git" "spl-linux-zen-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=4e9b156960562373e005798575a3fbc6d66e32ff")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-zen-git" "zfs-utils-common-git>=0.7.0.r200.gd4677269f" "linux-zen=4.14.3-1")
-
-pkgver() {
- cd "${srcdir}/zfs"
- echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.14.3.1
-}
+depends=("kmod" "spl-linux-zen-git" "zfs-utils-common-git=2017.12.08.r3208.4e9b15696" "linux-zen=4.14.5-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.3-1-zen/build \
- --with-linux-obj=/usr/lib/modules/4.14.3-1-zen/build
+ --libexecdir=/usr/lib/zfs-0.7.4 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.5-1-zen/build \
+ --with-linux-obj=/usr/lib/modules/4.14.5-1-zen/build
make
}
@@ -49,6 +44,7 @@ package_zfs-linux-zen-git() {
provides=("zfs")
groups=("archzfs-linux-zen-git")
conflicts=('zfs-linux-zen')
+ replaces=("zfs-git")
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
@@ -59,10 +55,10 @@ package_zfs-linux-zen-git() {
package_zfs-linux-zen-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.3-1-zen/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.5-1-zen/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 29701fba8e59..c1519874f3bb 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.3-1-zen
+ depmod -a 4.14.5-1-zen
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'