summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2fcc2ea8aaf..5cc19f716c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,6 +68,14 @@ prepare() {
popd > /dev/null;
}
+check() {
+ hello_file="$(realpath ../hello.zig)"
+ cd "${srcdir}/zig-linux-${CARCH}-${pkgver//_/-}";
+ echo "Running Zig Hello World"
+ ./zig run "$hello_file"
+ ./zig test "$hello_file"
+}
+
package() {
cd "${srcdir}/zig-linux-${CARCH}-${pkgver//_/-}"
install -d "${pkgdir}/usr/bin"