summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD77
2 files changed, 36 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebc4c60af797..689f3a2f655d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = zlib-ng-git
- pkgdesc = zlib replacement with optimizations for "next generation" systems
- pkgver = 2
+ pkgdesc = Zlib data compression library for the next generation systems
+ pkgver = r1918.41faa084
pkgrel = 1
- epoch = 3
url = https://github.com/zlib-ng/zlib-ng
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = armv7h
+ arch = aarch64
license = custom
- makedepends = cmake
makedepends = git
depends = glibc
- provides = zlib=1.2.11
- provides = zlib-ng
- conflicts = zlib
- conflicts = zlib-ng
- options = staticlibs
+ options = !emptydirs
source = git+https://github.com/zlib-ng/zlib-ng.git
- b2sums = SKIP
+ md5sums = SKIP
pkgname = zlib-ng-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 90d16f565566..1eec35015c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,36 @@
-# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+# Maintainer: MGislv <mgislv at ceppo dot xyz>
+# Contributor: Diab Neiroukh <lazerl0rd at thezest dot dev>
+# Contributor: Jacek Szafarkiewicz <szafar at linux dot pl>
-pkgname="zlib-ng-git"
-pkgver=2
+pkgname=zlib-ng-git
+pkgver=r1918.41faa084
pkgrel=1
-epoch=3
-pkgdesc="zlib replacement with optimizations for \"next generation\" systems"
-arch=(
- "any"
-)
-url="https://github.com/zlib-ng/zlib-ng"
-license=(
- "custom"
-)
-depends=(
- "glibc"
-)
-makedepends=(
- "cmake"
- "git"
-)
-provides=(
- "zlib=1.2.11"
- "zlib-ng"
-)
-conflicts=(
- "zlib"
- "zlib-ng"
-)
-options=(
- "staticlibs"
-)
-source=(
- "git+${url}.git"
-)
-b2sums=(
- "SKIP"
-)
+pkgdesc='Zlib data compression library for the next generation systems'
+url='https://github.com/zlib-ng/zlib-ng'
+arch=('x86_64' 'i686' 'pentium4' 'armv7h' 'aarch64')
+license=('custom')
+depends=('glibc')
+makedepends=('git')
+options=('!emptydirs')
+source=("git+$url.git")
+md5sums=('SKIP')
-build()
-{
- cd "zlib-ng" || exit
- ./configure --prefix="/usr" --zlib-compat
- make
+pkgver() {
+ cd zlib-ng
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-check()
-{
- cd "zlib-ng" || exit
- make test
+build() {
+ cd zlib-ng
+ CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" ./configure --prefix=/usr
+ make
}
-package()
-{
- cd "zlib-ng" || exit
- make install DESTDIR="${pkgdir}"
+check() {
+ make -C zlib-ng test
+}
- install -D -m644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+package() {
+ make DESTDIR="$pkgdir" -C zlib-ng install
+ install -Dm644 zlib-ng/LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}