summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22a5a434a743..7f919ad9f0e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = zlib-ng-git
pkgdesc = zlib replacement with optimizations for "next generation" systems
pkgver = 1.9.9
- pkgrel = 3
+ pkgrel = 1
+ epoch = 1
url = https://github.com/zlib-ng/zlib-ng
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index b8767055023b..16b09495baa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname="zlib-ng-git"
pkgver=1.9.9
-pkgrel=3
+pkgrel=1
+epoch=1
pkgdesc="zlib replacement with optimizations for \"next generation\" systems"
arch=("any")
url="https://github.com/zlib-ng/zlib-ng"
@@ -12,10 +13,14 @@ makedepends=("cmake" "git")
provides=("zlib=1.2.11" "zlib-ng=1.9.9")
conflicts=("zlib-ng")
options=("staticlibs")
-source=("git+${url}.git"
- "zlib-ng.conf")
-b2sums=("SKIP"
- "bf6eb01985db45c6b209a981aa5dbb97c9533fac960cd92ad9aee2d7926f0ec0e133f7df65901ced722fc51bdb362c6bfa3442c8d023db079b6636d109856071")
+source=(
+ "git+${url}.git"
+ "zlib-ng.conf"
+)
+b2sums=(
+ "SKIP"
+ "bf6eb01985db45c6b209a981aa5dbb97c9533fac960cd92ad9aee2d7926f0ec0e133f7df65901ced722fc51bdb362c6bfa3442c8d023db079b6636d109856071"
+)
build()
{
@@ -37,5 +42,5 @@ package()
cd "zlib-ng"
make install DESTDIR="${pkgdir}"
- install -D -m644 "LICENSE.md" "${pkgdir}/usr/share/licenses/zlib-ng/LICENSE"
+ install -D -m644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}