summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6f305f9f6b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zlib-zpipe
+ pkgdesc = example of proper use of zlib's inflate() and deflate(), also a nice filtering compression solution
+ pkgver = 1.2.11
+ pkgrel = 1
+ url = https://www.zlib.net/
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = https://zlib.net/zlib-1.2.11.tar.gz
+ source = https://zlib.net/zlib-1.2.11.tar.gz.asc
+ validpgpkeys = 5ED46A6721D365587791E2AA783FCD8E58BCAFBA
+ md5sums = 1c9f62f0778697a09d36121ead88e08e
+ md5sums = SKIP
+
+pkgname = zlib-zpipe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfe450ca8f91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=zlib-zpipe
+pkgver=1.2.11
+pkgrel=1
+pkgdesc="example of proper use of zlib's inflate() and deflate(), also a nice filtering compression solution"
+arch=('x86_64')
+license=('custom')
+url="https://www.zlib.net/"
+depends=('glibc')
+source=("https://zlib.net/zlib-${pkgver}.tar.gz"{,.asc})
+md5sums=('1c9f62f0778697a09d36121ead88e08e'
+ 'SKIP')
+validpgpkeys=('5ED46A6721D365587791E2AA783FCD8E58BCAFBA')
+
+prepare() {
+ cd zlib-$pkgver
+ grep -A 24 '^ Copyright' zlib.h > LICENSE
+}
+
+build() {
+ cd zlib-$pkgver/examples
+ gcc -o zlib-zpipe -lz zpipe.c
+}
+
+package() {
+ cd zlib-$pkgver
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 examples/$pkgname "$pkgdir"/usr/bin/$pkgname
+}