summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--zls.install4
3 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1dcd1fb3c29..560fe80cd9cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zls-bin
pkgdesc = Zig Language Server, or zls, is a language server for Zig. Pre-compiled official binary.
- pkgver = 0.9.0
- pkgrel = 2
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://github.com/zigtools/zls
install = zls.install
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = zls-bin
replaces = zls
replaces = zls-git
noextract = zls-LICENSE.txt
- source = zls-LICENSE.txt::https://raw.githubusercontent.com/zigtools/zls/0.9.0/LICENSE
+ source = zls-LICENSE.txt::https://raw.githubusercontent.com/zigtools/zls/0.10.0/LICENSE
sha256sums = 39d99dfbe269e3daf483652bd925f4955e3b2a3d11fd737b538d366ef358c3ce
- source_x86_64 = zls-bin-0.9.0.tar.gz::https://github.com/zigtools/zls/releases/download/0.9.0/x86_64-linux.tar.xz
- sha256sums_x86_64 = f001967764565ab72e38c9320309fbbaf45f122ba01c80a2433b400f942bd18d
+ source_x86_64 = zls-bin-0.10.0.tar.gz::https://github.com/zigtools/zls/releases/download/0.10.0/x86_64-linux.tar.zst
+ sha256sums_x86_64 = 3c25891dd39e0073ef0ef3117aba724a63264de85583bceccea7718577a61acf
pkgname = zls-bin
diff --git a/PKGBUILD b/PKGBUILD
index 96f3de9969e9..3eb38259e257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nicholas Schlabach <Techcable at techcable dot net>
pkgname=zls-bin
-pkgver="0.9.0"
-pkgrel=2
+pkgver="0.10.0"
+pkgrel=1
pkgdesc="Zig Language Server, or zls, is a language server for Zig. Pre-compiled official binary."
arch=('x86_64')
url="https://github.com/zigtools/zls"
@@ -15,28 +15,18 @@ install="zls.install"
# The MIT is considered a "custom" license, because it has a unique copyright line
#
# See the wiki for more info: https://wiki.archlinux.org/title/PKGBUILD#license
-source=("zls-LICENSE.txt::https://raw.githubusercontent.com/zigtools/zls/0.9.0/LICENSE")
+source=("zls-LICENSE.txt::https://raw.githubusercontent.com/zigtools/zls/0.10.0/LICENSE")
noextract=("zls-LICENSE.txt")
# This is the actual binary (everything except the license)
-source_x86_64=("$pkgname-$pkgver.tar.gz::https://github.com/zigtools/zls/releases/download/${pkgver}/${CARCH}-linux.tar.xz")
+source_x86_64=("$pkgname-$pkgver.tar.gz::https://github.com/zigtools/zls/releases/download/${pkgver}/${CARCH}-linux.tar.zst")
sha256sums=('39d99dfbe269e3daf483652bd925f4955e3b2a3d11fd737b538d366ef358c3ce')
-sha256sums_x86_64=('f001967764565ab72e38c9320309fbbaf45f122ba01c80a2433b400f942bd18d')
+sha256sums_x86_64=('3c25891dd39e0073ef0ef3117aba724a63264de85583bceccea7718577a61acf')
package() {
_output="${srcdir}"
install -Dm755 "${_output}/bin/zls" "${pkgdir}/usr/bin/zls"
- # Install `build_runner.zig into the /usr/bin directory, alongside the executable.
- #
- # According to the README.md file, this is the default location.
- #
- # Prior versions of zls-bin manually modified the zls.json configuration to
- # move build_runner.zig into /usr/share instead of /usr/bin
- #
- # This was IMO not worth the complexity. We'll just keep it in /usr/bin
- install -Dm644 "${_output}/bin/build_runner.zig" "${pkgdir}/usr/bin/build_runner.zig"
-
install -Dm644 "${_output}/README.md" "${pkgdir}/usr/share/zls/README.md"
# Install license file
install -Dm644 "${_output}/zls-LICENSE.txt" "${pkgdir}/usr/share/licenses/zls-bin/LICENSE"
diff --git a/zls.install b/zls.install
index 51209dbf0e09..b4c6403c6dc9 100644
--- a/zls.install
+++ b/zls.install
@@ -1,11 +1,11 @@
post_install() {
- echo "Consider runing 'zls config' to setup initial configuration"
+ echo "Consider runing 'zls --config' to setup initial configuration"
echo ""
echo "This is not required, but it is highly recommended"
}
post_upgrade() {
- echo "Consider re-running 'zls config' to reconfigure the language server"
+ echo "Consider re-running 'zls --config' to reconfigure the language server"
echo ""
echo "Some options may have changed when upgrading from $2 -> $1"
echo ""