summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a24e88af396f..0c96289d8a1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = zls-git
pkgdesc = Zig LSP implementation + Zig Language Server
- pkgver = r127.d9e5859
+ pkgver = r199.cffe4af
pkgrel = 1
url = https://github.com/zigtools/zls
arch = any
license = MIT
depends = zig
source = git+https://github.com/zigtools/zls
+ source = git+https://github.com/ziglibs/known-folders
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = zls-git
diff --git a/PKGBUILD b/PKGBUILD
index 20c4e6459fd7..631402145aef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,29 @@
_pkgbasename=zls
pkgname=${_pkgbasename}-git
pkgrel=1
-pkgver=r127.d9e5859
+pkgver=r199.cffe4af
pkgdesc="Zig LSP implementation + Zig Language Server"
arch=('any')
url="https://github.com/zigtools/${_pkgbasename}"
license=('MIT')
depends=('zig')
-source=(git+https://github.com/zigtools/${_pkgbasename})
-sha256sums=('SKIP')
+source=(git+https://github.com/zigtools/${_pkgbasename}
+ git+https://github.com/ziglibs/known-folders)
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${srcdir}/${_pkgbasename}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_pkgbasename}"
+ git submodule init
+ git config submodule.known-folders.url "$srcdir"/known-folders
+ git submodule update
+}
+
build() {
cd "${srcdir}/${_pkgbasename}"
zig build -Drelease-fast