summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38a78d9a4705..8f8d9edf0c67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = zmeventnotification-git
pkgdesc = Event Notification Server sits along with ZoneMinder and offers real time notifications, support for push notifications as well as Machine Learning powered recognition + hooks
- pkgver = v4.6.1.r58.geab8548
- pkgrel = 4
+ pkgver = v5.4.1.r17.g53f9e83
+ pkgrel = 1
url = https://github.com/pliablepixels/zmeventnotification
arch = x86_64
license = GPL
license = MIT
makedepends = cmake
- makedepends = wget
makedepends = git
depends = perl-crypt-mysql
depends = perl-config-inifiles
@@ -19,6 +18,8 @@ pkgbase = zmeventnotification-git
depends = perl-net-mqtt-simple
depends = perl-config-inifiles
depends = opencv
+ depends = qt5-base
+ depends = python-requests
depends = geos
depends = hdf5
depends = python-numpy
@@ -39,8 +40,8 @@ pkgbase = zmeventnotification-git
source = yolov3_classes.txt::https://raw.githubusercontent.com/pjreddie/darknet/master/data/coco.names
source = https://pjreddie.com/media/files/yolov3.weights
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 22489ea38575dfa36c67a90048e8759576416a79d32dc11e15d2217777b9a953
+ sha256sums = 634a1132eb33f8091d60f2c346ababe8b905ae08387037aed883953b7329af84
sha256sums = 523e4e69e1d015393a1b0a441cef1d9c7659e3eb2d7e15f793f060a21b32f297
pkgname = zmeventnotification-git
diff --git a/PKGBUILD b/PKGBUILD
index febb8802a2b2..f87a8032ae15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=zmeventnotification-git
_pkgname=zmeventnotification
-pkgver=v4.6.1.r58.geab8548
-pkgrel=4
+pkgver=v5.4.1.r17.g53f9e83
+pkgrel=1
pkgdesc='Event Notification Server sits along with ZoneMinder and offers real time notifications, support for push notifications as well as Machine Learning powered recognition + hooks'
arch=('x86_64')
url='https://github.com/pliablepixels/zmeventnotification'
license=('GPL' 'MIT')
depends=('perl-crypt-mysql' 'perl-config-inifiles' 'perl-crypt-eksblowfish' 'perl-net-websocket-server' 'perl-json' 'perl-lwp-protocol-https'
- 'perl-io-socket-ssl' 'perl-net-mqtt-simple' 'perl-config-inifiles' 'opencv'
+ 'perl-io-socket-ssl' 'perl-net-mqtt-simple' 'perl-config-inifiles' 'opencv' 'qt5-base' 'python-requests'
#hooks
'geos' 'hdf5' 'python-numpy' 'python-imutils' 'python-pyzm-git' 'python-sqlalchemy' 'python-psutil' 'python-future' 'python-shapely' 'python-mysql-connector'
'python-scikit-learn' 'python-face_recognition'
)
-makedepends=('cmake' 'wget' 'git')
+makedepends=('cmake' 'git')
optdepends=()
conflicts=()
backup=('etc/zoneminder/objectconfig.ini' 'etc/zoneminder/secrets.ini' 'etc/zoneminder/zmeventnotification.ini')
@@ -26,10 +26,9 @@ source=("git://github.com/pliablepixels/$_pkgname.git"
'https://pjreddie.com/media/files/yolov3.weights'
)
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- '523e4e69e1d015393a1b0a441cef1d9c7659e3eb2d7e15f793f060a21b32f297'
-)
+ '22489ea38575dfa36c67a90048e8759576416a79d32dc11e15d2217777b9a953'
+ '634a1132eb33f8091d60f2c346ababe8b905ae08387037aed883953b7329af84'
+ '523e4e69e1d015393a1b0a441cef1d9c7659e3eb2d7e15f793f060a21b32f297')
pkgver() {
cd "$_pkgname"