summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--znc-q.hook9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d03c82bea94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = znc-q-git
+ pkgdesc = ZNC module for authenticating with QuakeNets Q bot
+ pkgver = r2.320779f
+ pkgrel = 1
+ url = https://github.com/jkhsjdhjs/znc-q
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = znc
+ source = znc-q::git+https://github.com/jkhsjdhjs/znc-q
+ source = znc-q.hook
+ sha512sums = SKIP
+ sha512sums = 7e04b60b096867b80979b2b82949d0f2df3e4c4af3ecb56667b89fee17640a7baabb7e505a7451344f55af13df962a7f7b612b5406a02a3d346357ae0e09cda4
+
+pkgname = znc-q-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e16691ef09ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Leon Möller <jkhsjdhjs at totally dot rip>
+
+pkgname=znc-q-git
+pkgver=r2.320779f
+pkgrel=1
+pkgdesc="ZNC module for authenticating with QuakeNets Q bot"
+arch=('any')
+url="https://github.com/jkhsjdhjs/znc-q"
+license=('Apache')
+makedepends=('git')
+depends=('znc')
+source=("${pkgname%-git}::git+https://github.com/jkhsjdhjs/znc-q"
+ 'znc-q.hook')
+sha512sums=('SKIP'
+ '7e04b60b096867b80979b2b82949d0f2df3e4c4af3ecb56667b89fee17640a7baabb7e505a7451344f55af13df962a7f7b612b5406a02a3d346357ae0e09cda4')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ znc-buildmod q.cpp
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 q.so "$pkgdir/usr/lib/znc/q.so"
+ install -Dm644 ../znc-q.hook "$pkgdir/usr/share/libalpm/hooks/znc-q.hook"
+}
diff --git a/znc-q.hook b/znc-q.hook
new file mode 100644
index 000000000000..a7641d4654e0
--- /dev/null
+++ b/znc-q.hook
@@ -0,0 +1,9 @@
+[Trigger]
+Type = Package
+Operation = Upgrade
+Target = znc
+
+[Action]
+Description = znc has been updated...
+When = PostTransaction
+Exec = /usr/bin/echo " -> You probably have to rebuild znc-q-git!"