summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO11
-rw-r--r--[-rwxr-xr-x]PKGBUILD35
3 files changed, 28 insertions, 31 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 6d051d6f04b7..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,13 +0,0 @@
-pkgbase = znotes
- pkgdesc = Lightweight crossplatform application for notes managment with simple interface
- pkgver = 0.4.5
- pkgrel = 5
- url = http://znotes.sourceforge.net
- arch = i686
- arch = x86_64
- license = GPL
- depends = qt4
- source = https://github.com/proton/zNotes/archive/master.zip
-
-pkgname = znotes
-
diff --git a/.SRCINFO b/.SRCINFO
index c2603e06d9c8..654afde8d409 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = znotes
pkgdesc = Lightweight crossplatform application for notes managment with simple interface
- pkgver = 0.4.5
- pkgrel = 7
+ pkgver = 0.4.7
+ pkgrel = 1
url = http://znotes.sourceforge.net
arch = i686
arch = x86_64
license = GPL
- depends = qt5-base
- source = https://github.com/proton/zNotes/archive/master.zip
- md5sums = 9604bc0f00aa169c6caac8f2ccad98ab
+ depends = qt5-tools
+ source = https://github.com/proton/zNotes/archive/refs/tags/0.4.7.tar.gz
+ md5sums = f0d35e50bac515503ee13bce3eb480d0
pkgname = znotes
-
diff --git a/PKGBUILD b/PKGBUILD
index 0abd347b7acb..197361dc1975 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
-# Maintainer: Alois Nespor <info@aloisnespor.info>
+# Maintainer: Uffe Jakobsen <>
+# Contributor: Alois Nespor <info@aloisnespor.info>
# Contributor: Kosava <kosava@archlinux.us>
+_pkgname=zNotes
+
pkgname=znotes
-pkgver=0.4.5
-pkgrel=7
+pkgver=0.4.7
+pkgrel=1
pkgdesc="Lightweight crossplatform application for notes managment with simple interface"
arch=('i686' 'x86_64')
url="http://znotes.sourceforge.net"
license=('GPL')
-depends=('qt5-base')
-source=(https://github.com/proton/zNotes/archive/master.zip)
-md5sums=('SKIP')
+depends=('qt5-tools')
+source=(https://github.com/proton/zNotes/archive/refs/tags/${pkgver}.tar.gz)
+md5sums=('f0d35e50bac515503ee13bce3eb480d0')
+#
+#
+#
-build() {
- cd $srcdir/zNotes-master
+build()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
lrelease-qt5 znotes.pro
qmake-qt5 QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" QMAKE_LFLAGS_RELEASE="$LDFLAGS" PREFIX=/usr
make
}
-package() {
- cd $srcdir/zNotes-master
- make INSTALL_ROOT=$pkgdir install
+package()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make INSTALL_ROOT=${pkgdir} install
}
-md5sums=('9604bc0f00aa169c6caac8f2ccad98ab')
+
+#
+# EOF
+#