summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD37
-rwxr-xr-xgenerate.sh39
-rw-r--r--zoho-mail-desktop.desktop10
4 files changed, 20 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa57f6e7409f..03a312d2c293 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = zoho-mail-desktop
pkgdesc = The desktop version of your favorite mailsuite!
pkgver = 1.2.0
- pkgrel = 3
+ pkgrel = 5
url = https://www.zoho.com/mail/
arch = x86_64
license = custom
source = https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v1.2.0.AppImage
- sha256sums = 106801eba31665f806dda8d78ad192b6464e69c85a041d08937433b4e74f19cb
+ sha256sums = SKIP
pkgname = zoho-mail-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 29e7dafbccb1..1df450e343ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,32 @@
pkgname=zoho-mail-desktop
pkgver=1.2.0
-pkgrel=3
+pkgrel=5
pkgdesc="The desktop version of your favorite mailsuite!"
arch=('x86_64')
license=('custom')
url="https://www.zoho.com/mail/"
-options=()
-sha256sums=('106801eba31665f806dda8d78ad192b6464e69c85a041d08937433b4e74f19cb')
source=("https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v${pkgver}.AppImage")
+sha256sums=("SKIP")
prepare() {
- chmod +x zoho-mail-desktop-x64-v${pkgver}.AppImage
- ./zoho-mail-desktop-x64-v${pkgver}.AppImage --appimage-extract
- }
+ chmod +x "zoho-mail-desktop-x64-v${pkgver}.AppImage"
+ ./"zoho-mail-desktop-x64-v${pkgver}.AppImage" --appimage-extract
+}
package() {
- mkdir -p "${pkgdir}/opt/"
- cp -R "${srcdir}/squashfs-root/" "${pkgdir}/opt/${pkgname}"
- chmod -R 755 "${pkgdir}/opt/${pkgname}"
-
- mkdir -p "${pkgdir}/usr/share/"
- cp -R "${srcdir}/squashfs-root/usr/share/icons/" "${pkgdir}/usr/share/"
-
- mkdir -p "${pkgdir}/usr/share/applications/"
- cp "../zoho-mail-desktop.desktop" "${pkgdir}/usr/share/applications/"
-
+ mkdir -p "${pkgdir}/opt/zoho-mail-desktop"
+ cp -r "${srcdir}/squashfs-root" "${pkgdir}/opt/zoho-mail-desktop"
+
mkdir -p "${pkgdir}/usr/bin"
- ln -s "${pkgdir}/opt/zoho-mail-desktop/AppRun" "${pkgdir}/usr/bin/zoho-mail-desktop"
- }
-
+ cp -r "${pkgdir}/opt/zoho-mail-desktop/squashfs-root/AppRun" "${pkgdir}/usr/bin/zoho-mail-desktop"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp -r "${srcdir}/squashfs-root/zoho-mail-desktop.desktop" "${pkgdir}/usr/share/applications"
+
+ for img in 1024x1024 128x128 16x16 24x24 256x256 32x32 48x48 512x512 64x64 96x96; do
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/${img}/apps"
+ cp -r "${srcdir}/squashfs-root/usr/share/icons/hicolor/${img}/apps/zoho-mail-desktop.png" "${pkgdir}/usr/share/icons/hicolor/${img}/apps/"
+ done
+}
diff --git a/generate.sh b/generate.sh
deleted file mode 100755
index 765642e7637e..000000000000
--- a/generate.sh
+++ /dev/null
@@ -1,39 +0,0 @@
-REPO="ssh://aur@aur.archlinux.org/zoho-mail-desktop.git"
-
-echo "[#] Generating .SRCINFO"
-makepkg --printsrcinfo > .SRCINFO
-
-function GIT_MAKE {
- echo "[?] What files would you like to commit?"
- ls -A | grep -v ".git" | grep -v ".gitignore"
- read -p "[>>] " GIT_FILES
-
- echo "[?] Please type a commit message."
- read -p "[>>] " GIT_MESSAGE
-
- echo "[#] Make sure this looks good."
-
- echo "[#] Committing:"
- echo " ${GIT_FILES}"
- echo " With message:"
- echo " ${GIT_MESSAGE}"
-
- echo "[?] Look good?"
- echo "[?] Please type in 'yes' or 'no'."
- read -p "[>>] " GIT_CONFIRM; }
-
-GIT_MAKE
-
-while [[ ${GIT_CONFIRM} != "yes" ]] && [[ ${GIT_CONFIRM} != "no" ]]; do
- echo "[!] Invalid option provided."
- echo "[!] Please try again with 'yes' or 'no'."
- read -p "[>>] " GIT_CONFIRM; done
-
-while [[ ${GIT_CONFIRM} == "no" ]]; do
- echo "[#] Kk, let's try this again."
- GIT_MAKE; done
-
-echo "[@] Pushing to '${REPO}'"
-git add ${GIT_FILES}
-git commit -m "${GIT_MESSAGE}"
-git push
diff --git a/zoho-mail-desktop.desktop b/zoho-mail-desktop.desktop
deleted file mode 100644
index 0924dcc10a7f..000000000000
--- a/zoho-mail-desktop.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name=Zoho Mail - Desktop
-Exec=/opt/zoho-mail-desktop/AppRun
-Terminal=false
-Type=Application
-Icon=zoho-mail-desktop
-StartupWMClass=Zoho Mail - Desktop
-Comment=The desktop version of your favorite mailsuite!
-MimeType=x-scheme-handler/mailto;
-Categories=Office;