summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD9
-rw-r--r--log.txt23
-rw-r--r--uio.patch22
3 files changed, 51 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d6f415c09c0..01775d37aa58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,15 +45,17 @@ source=(
https://github.com/ZoneMinder/ZoneMinder/archive/$pkgver.tar.gz
httpd-zoneminder.conf
zoneminder.service
+ uio.patch
fabs.patch
zoneminder-tmpfile.conf
)
-sha256sums=('5461350caa9d8ec58deb1ef08e2e1641084e694f2a9f9e17b3b678b1a43203c7'
+sha256sums=('9451683808867c2382325dd8dac6049c138fa9d407fb81d29ecf5598dc75d581'
'ff7382b38ac07dadead0ad4d583e3dbcf8da4aaa06b76d048ee334f69f95db67'
'043d77a995553c533d62f48db4b719d29cf6c7074f215d866130e97be57ed646'
+ 'd1816cac69be5e807d22c37fcbe6fef99e38151a5c71233b875c0ebf101fb460'
'fd20faed09eaf825933c2a87b1d04febf99d183b2b36b0041df1e2b2990c49c2'
- 'cc8af737c3c07750fc71317c81999376e4bbb39da883780164a8747b3d7c95a7'
- )
+ 'cc8af737c3c07750fc71317c81999376e4bbb39da883780164a8747b3d7c95a7')
+
prepare () {
cd $srcdir/ZoneMinder-$pkgver/web/api/app/Plugin/
@@ -63,6 +65,7 @@ prepare () {
mv crud/* Crud
fi
patch $srcdir/ZoneMinder-$pkgver/src/zm_image.cpp < $srcdir/fabs.patch
+ patch $srcdir/ZoneMinder-$pkgver/src/zm_comms.h < $srcdir/uio.patch
}
build() {
diff --git a/log.txt b/log.txt
new file mode 100644
index 000000000000..09e54b17e59e
--- /dev/null
+++ b/log.txt
@@ -0,0 +1,23 @@
+==> Making package: zoneminder 1.30.4-1 (Fri Sep 15 20:35:45 UTC 2017)
+==> Checking runtime dependencies...
+==> Missing dependencies:
+ -> mariadb
+ -> perl-dbd-mysql
+ -> perl-dbi
+ -> apache
+ -> php
+ -> php-apache
+ -> php-gd
+ -> php-mcrypt
+ -> perl-libwww
+ -> vlc
+ -> perl-archive-zip
+ -> perl-date-manip
+ -> perl-mime-lite
+ -> perl-mime-tools
+==> Checking buildtime dependencies...
+==> Missing dependencies:
+ -> netpbm
+==> ERROR: Could not resolve all dependencies.
+
+==> ERROR: An unknown error has occurred. Exiting...
diff --git a/uio.patch b/uio.patch
new file mode 100644
index 000000000000..a892e29b1923
--- /dev/null
+++ b/uio.patch
@@ -0,0 +1,22 @@
+--- src/ZoneMinder-1.30.4/src/zm_comms.h 2017-05-09 14:54:48.000000000 +0000
++++ src/ZoneMinder-1.30.4/src/zm_comms.fix.h 2017-09-15 20:49:46.992445289 +0000
+@@ -21,7 +21,6 @@
+ #define ZM_COMMS_H
+
+ #include "zm_exception.h"
+-
+ #include <string.h>
+ #include <unistd.h>
+ #include <netdb.h>
+@@ -31,11 +30,9 @@
+ #include <set>
+ #include <vector>
+
+-#if defined(BSD)
+ #include <sys/uio.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+-#endif
+
+ class CommsException : public Exception
+ {