summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD25
-rw-r--r--httpd-zoneminder.conf4
-rw-r--r--zoneminder.install18
-rw-r--r--zoneminder.service4
4 files changed, 25 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53aafdd5088a..f3a3b10514ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
# Maintainer: Troy Will <troydwill at gmail dot com>
-# Contributor: Charles Spence IV <cspence@unomaha.edu>
# Contributor: /dev/rs0 </dev/rs0@secretco.de.com>
# Contributor: Jacek Burghardt <jacek@hebe.us>
# Contributor: Vojtech Aschenbrenner <v@asch.cz>
@@ -7,11 +6,13 @@
# Contributor: Ross melin <rdmelin@gmail.com>
# Contributor (Parabola): Márcio Silva <coadde@lavabit.com>
# Contributor (Parabola): André Silva <emulatorman@lavabit.com>
+# Contributor: Charles Spence IV <cspence@unomaha.edu>
+# Contributor: Joe Julian <me@joejulian.name>
# Orginally based on a Debian Squeeze package
_pkgname=zoneminder
pkgname=zoneminder
pkgver=1.28.1
-pkgrel=4
+pkgrel=6
pkgdesc='Capture, analyse, record and monitor video security cameras'
arch=( i686 x86_64 mips64el arm armv7h )
backup=( etc/zm.conf )
@@ -45,8 +46,8 @@ source=(
zoneminder-tmpfile.conf
)
sha256sums=('e55fa6ce1fd6c27912cd1de67fca3f80fad579f330020a384dc82838704d11ba'
- 'c2ca71ec57e53da040de61ff212ac063574e5ddfb4c333b70be060d5ec26c62c'
- '7eb2f26246e240e23502da44854d5ed14485aa11bc448ad73e9b57fee13f00a3'
+ 'ff7382b38ac07dadead0ad4d583e3dbcf8da4aaa06b76d048ee334f69f95db67'
+ '043d77a995553c533d62f48db4b719d29cf6c7074f215d866130e97be57ed646'
'cc8af737c3c07750fc71317c81999376e4bbb39da883780164a8747b3d7c95a7'
)
@@ -64,8 +65,8 @@ build() {
-DZM_CONTENTDIR=/var/cache/zoneminder \
-DZM_LOGDIR=/var/log/zoneminder \
-DZM_RUNDIR=/run/zoneminder \
- -DZM_TMPDIR=/srv/zoneminder/tmp \
- -DZM_SOCKDIR=/srv/zoneminder/socks .
+ -DZM_TMPDIR=/var/lib/zoneminder/temp \
+ -DZM_SOCKDIR=/var/lib/zoneminder/sock .
make V=0
}
@@ -84,13 +85,13 @@ package() {
mkdir -pv $pkgdir/var/{cache/zoneminder,log/zoneminder}
chown -Rv http.http $pkgdir/var/{cache/zoneminder,log/zoneminder}
- mkdir -v $pkgdir/srv/zoneminder
- chown -v http.http $pkgdir/srv/zoneminder
- mkdir -v $pkgdir/srv/zoneminder/socks
- chown -v http.http $pkgdir/srv/zoneminder/socks
+ # corresponds to -DZM_SOCKDIR=/var/lib/zoneminder/sock
+ mkdir -pv $pkgdir/var/lib/zoneminder/sock
+ chown -v http.http $pkgdir/var/lib/zoneminder/sock
- mkdir -pv $pkgdir/srv/zoneminder/tmp
- chown -v http.http $pkgdir/srv/zoneminder/tmp
+ # corresponds to -DZM_TMPDIR=/var/lib/zoneminder/temp
+ mkdir -pv $pkgdir/var/lib/zoneminder/temp
+ chown -v http.http $pkgdir/var/lib/zoneminder/temp
chown -v http.http $pkgdir/etc/zm.conf
chmod 0700 $pkgdir/etc/zm.conf
diff --git a/httpd-zoneminder.conf b/httpd-zoneminder.conf
index 7e6c8e375084..41b364f13168 100644
--- a/httpd-zoneminder.conf
+++ b/httpd-zoneminder.conf
@@ -7,8 +7,8 @@ Alias /zm "/srv/http/zoneminder"
AllowOverride None
Order allow,deny
Allow from all
- # Provide PHP access to important directories
- php_admin_value open_basedir "/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/:/etc/zm.conf:/srv/http/zoneminder/:/var/cache/zoneminder/:/srv/zoneminder/socks/:/var/log/zoneminder/"
+ # Provide PHP directory and file access, see http://php.net/manual/en/ini.core.php#ini.open-basedir
+ php_admin_value open_basedir "/tmp/:/etc/zm.conf:/srv/http/zoneminder/:/var/cache/zoneminder/:/var/lib/zoneminder/:/var/log/zoneminder/"
</Directory>
ScriptAlias /cgi-bin "/srv/http/cgi-bin"
diff --git a/zoneminder.install b/zoneminder.install
index acfd93463514..d16779e3b25e 100644
--- a/zoneminder.install
+++ b/zoneminder.install
@@ -23,11 +23,11 @@ post_install() {
# Zoneminder needs Apache configured to permit CGI execution
\|^\t#LoadModule cgi_module modules/mod_cgi.so$| s|\t#|\t|;
- # libphp5
- \|^LoadModule php5_module modules/libphp5.so$|d;
- s|^#*LoadModule rewrite_module modules/mod_rewrite.so$|&\nLoadModule php5_module modules/libphp5.so|;
- \|^Include /etc/httpd/conf/extra/php5_module.conf|d;
- s|^Include conf/extra/httpd-default.conf$|&\nInclude /etc/httpd/conf/extra/php5_module.conf|;
+ # libphp7
+ \|^LoadModule php7_module modules/libphp7.so$|d;
+ s|^#*LoadModule rewrite_module modules/mod_rewrite.so$|&\nLoadModule php7_module modules/libphp7.so|;
+ \|^Include /etc/httpd/conf/extra/php7_module.conf|d;
+ s|^Include conf/extra/httpd-default.conf$|&\nInclude /etc/httpd/conf/extra/php7_module.conf|;
# Include httpd-zoneminder.conf
\|^Include /etc/httpd/conf/extra/httpd-zoneminder.conf$|d;
@@ -66,9 +66,9 @@ post_install() {
Apache configuration
--------------------
Edit /etc/httpd/conf/httpd.conf and add the line:
- "LoadModule php5_module modules/libphp5.so"
+ "LoadModule php7_module modules/libphp7.so"
and:
- "Include /etc/httpd/conf/extra/php5_module.conf"
+ "Include /etc/httpd/conf/extra/php7_module.conf"
"Include /etc/httpd/conf/extra/httpd-zoneminder.conf"
EOF
@@ -105,8 +105,8 @@ Note:
==> Disable http with php if it isn't needed with others servers,
==> comment or remove that lines in /etc/httpd/conf/httpd.conf:
-==> "LoadModule php5_module modules/libphp5.so"
-==> "Include /etc/httpd/conf/extra/php5_module.conf"
+==> "LoadModule php7_module modules/libphp7.so"
+==> "Include /etc/httpd/conf/extra/php7_module.conf"
==> Remove line in /etc/httpd/conf/httpd.conf:
==> "Include /etc/httpd/conf/extra/httpd-zoneminder.conf"
diff --git a/zoneminder.service b/zoneminder.service
index 4ba745844503..48268f1391d8 100644
--- a/zoneminder.service
+++ b/zoneminder.service
@@ -1,5 +1,3 @@
-# ZoneMinder systemd unit file for Arch Linux
-
[Unit]
Description=ZoneMinder CCTV recording and security system
After=network.target mysqld.service httpd.service
@@ -11,7 +9,7 @@ Type=forking
ExecStart=/usr/bin/zmpkg.pl start
ExecReload=/usr/bin/zmpkg.pl restart
ExecStop=/usr/bin/zmpkg.pl stop
-PIDFile="/srv/zoneminder/zm.pid"
+PIDFile=/run/zoneminder/zm.pid
[Install]
WantedBy=multi-user.target