summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD41
-rw-r--r--Zoom.desktop13
-rw-r--r--zoom.xml7
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc3356f203bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = zoom-x32
+ pkgdesc = Video Conferencing and Web Conferencing Service
+ pkgver = 5.1.412382.0614
+ pkgrel = 1
+ url = https://zoom.us/
+ arch = i686
+ license = custom
+ depends = fontconfig
+ depends = glib2
+ depends = libpulse
+ depends = libsm
+ depends = ttf-font
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxfixes
+ depends = libxi
+ depends = libxcursor
+ depends = libxkbcommon-x11
+ depends = libxrandr
+ depends = libxrender
+ depends = libxshmfence
+ depends = libxslt
+ depends = mesa
+ depends = nss
+ depends = pulseaudio-alsa
+ depends = xcb-util-image
+ depends = xcb-util-keysyms
+ optdepends = qt5-webengine: SSO login support
+ optdepends = picom: extra compositor needed by some window managers for screen sharing
+ optdepends = xcompmgr: extra compositor needed by some window managers for screen sharing
+ options = !strip
+ source = Zoom.desktop
+ source = zoom.xml
+ source = https://zoom.us/client/latest/zoom_i686.tar.xz
+ sha256sums = aefdb65e4ee95ef98920ce4b184e5d9cd11f83dd16ecbda66aea75bd3a079ea5
+ sha256sums = 33e326f0c2dc8312b2fcbe3debe181e15871e87b8afdbbcbbff5e057f23be867
+ sha256sums = f21cf893041f839abfd8c063087fa0b82fe9ea448c3249c17a9ec89784686a94
+
+pkgname = zoom-x32
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67c32f760f87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: andrewb <andrea.benini96@gmail.com>
+
+_pkgname=zoom
+pkgname=zoom-x32
+pkgver=5.1.412382.0614
+pkgrel=1
+pkgdesc="Video Conferencing and Web Conferencing Service"
+arch=(i686)
+url="https://zoom.us/"
+license=('custom')
+depends=('fontconfig' 'glib2' 'libpulse' 'libsm' 'ttf-font' 'libx11' 'libxcb'
+ 'libxcomposite' 'libxfixes' 'libxi' 'libxcursor' 'libxkbcommon-x11' 'libxrandr'
+ 'libxrender' 'libxshmfence' 'libxslt' 'mesa' 'nss' 'pulseaudio-alsa'
+ 'xcb-util-image' 'xcb-util-keysyms')
+optdepends=('qt5-webengine: SSO login support'
+ 'picom: extra compositor needed by some window managers for screen sharing'
+ 'xcompmgr: extra compositor needed by some window managers for screen sharing')
+options=(!strip)
+source=(Zoom.desktop
+ $_pkgname.xml
+ https://zoom.us/client/latest/$_pkgname\_$arch.tar.xz)
+sha256sums=('aefdb65e4ee95ef98920ce4b184e5d9cd11f83dd16ecbda66aea75bd3a079ea5'
+ '33e326f0c2dc8312b2fcbe3debe181e15871e87b8afdbbcbbff5e057f23be867'
+ 'f21cf893041f839abfd8c063087fa0b82fe9ea448c3249c17a9ec89784686a94')
+
+
+package() {
+ install -dm755 "$pkgdir/opt"
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/share"
+
+ # Program
+ cp -r "$srcdir/$_pkgname" "$pkgdir/opt"
+ cp -r "$srcdir/$_pkgname/doc" "$pkgdir/usr/share/"
+
+ # Launcher and mime
+ ln -s /opt/$_pkgname/ZoomLauncher "$pkgdir/usr/bin/$_pkgname"
+ install -D Zoom.desktop "$pkgdir/usr/share/applications/Zoom.desktop"
+ install -D $_pkgname.xml "$pkgdir/usr/share/mime/packages/$_pkgname.xml"
+}
+
diff --git a/Zoom.desktop b/Zoom.desktop
new file mode 100644
index 000000000000..e1f1d3a486f6
--- /dev/null
+++ b/Zoom.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Zoom
+Comment=Zoom Video Conference
+Exec=/usr/bin/zoom %U
+Icon=Zoom.png
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Network;Application;
+StartupWMClass=Zoom
+MimeType=x-scheme-handler/zoommtg;x-scheme-handler/zoomus;x-scheme-handler/tel;x-scheme-handler/callto;x-scheme-handler/zoomphonecall;application/x-zoom
+X-KDE-Protocols=zoommtg;zoomus;tel;callto;zoomphonecall;
+Name[en_US]=Zoom
diff --git a/zoom.xml b/zoom.xml
new file mode 100644
index 000000000000..38d4616e79d4
--- /dev/null
+++ b/zoom.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-zoom">
+ <comment>Zoom Recording File</comment>
+ <glob pattern="*.zoom"/>
+ </mime-type>
+</mime-info>