summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3812f28fb8d5..0607addc2e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,13 +3,14 @@ pkgbase = zps-git
pkgver = 1.2.3.r0.g9d08c49
pkgrel = 1
url = https://github.com/orhun/zps
- arch = any
+ arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
+ provides = zps
conflicts = zps
conflicts = zps-bin
- source = git://github.com/orhun/zps.git
+ source = git+https://github.com/orhun/zps
sha256sums = SKIP
pkgname = zps-git
diff --git a/PKGBUILD b/PKGBUILD
index 13799c35ca9e..c9039ae67b60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@ pkgname=zps-git
pkgdesc="A small utility for listing and reaping zombie processes (git)"
pkgver=1.2.3.r0.g9d08c49
pkgrel=1
-arch=('any')
+arch=('x86_64')
url="https://github.com/orhun/zps"
license=('GPL3')
makedepends=('git' 'cmake')
conflicts=("${pkgname%-git}" "${pkgname%-git}-bin")
-source=('git://github.com/orhun/zps.git')
+provides=("${pkgname%-git}")
+source=("git+$url")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}