summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad86bd529b97..8d3ae9b87ac3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zrythm
pkgdesc = An highly automated, intuitive, Digital Audio Workstation (DAW)
- pkgver = 0.6.003
- pkgrel = 2
+ pkgver = 0.6.039
+ pkgrel = 1
url = https://www.zrythm.org
arch = x86_64
arch = i686
@@ -11,6 +11,8 @@ pkgbase = zrythm
makedepends = sed
makedepends = meson
makedepends = ninja
+ makedepends = help2man
+ makedepends = python-sphinx
depends = gtk3
depends = lv2
depends = lilv
@@ -26,10 +28,10 @@ pkgbase = zrythm
optdepends = portaudio: portaudio backend
optdepends = qt5-base: for embedding qt5 plugin UIs
conflicts = zrythm-git
- source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.003.tar.xz
- source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.003.tar.xz.asc
+ source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.039.tar.xz
+ source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.039.tar.xz.asc
validpgpkeys = 48132384AD3DF7D86E254B83022EAE42313D70F3
- sha256sums = f6ccc1cc43ccd2fe8cdfbf8a884303a50e52fcd504d331a7ba754ca2508e4e43
+ sha256sums = c9b04756085ba2158b08e18add99d608159f528f36f580cfadf462e134358288
sha256sums = SKIP
pkgname = zrythm
diff --git a/PKGBUILD b/PKGBUILD
index df48e1683f6e..0d2129e2bb07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
pkgname=zrythm
-pkgver=0.6.003
-pkgrel=2
+pkgver=0.6.039
+pkgrel=1
pkgdesc='An highly automated, intuitive, Digital Audio Workstation (DAW)'
arch=('x86_64' 'i686')
url='https://www.zrythm.org'
@@ -11,12 +11,12 @@ depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
'libsamplerate' 'alsa-lib'
'ladspa' 'fftw')
makedepends=('python' 'gettext' 'sed'
- 'meson' 'ninja')
+ 'meson' 'ninja' 'help2man' 'python-sphinx')
optdepends=('portaudio: portaudio backend'
'qt5-base: for embedding qt5 plugin UIs')
conflicts=('zrythm-git')
source=("https://download.savannah.nongnu.org/releases/$pkgname/$pkgname-$pkgver.tar.xz"{,.asc})
-sha256sums=('f6ccc1cc43ccd2fe8cdfbf8a884303a50e52fcd504d331a7ba754ca2508e4e43'
+sha256sums=('c9b04756085ba2158b08e18add99d608159f528f36f580cfadf462e134358288'
'SKIP')
validpgpkeys=('48132384AD3DF7D86E254B83022EAE42313D70F3')
@@ -25,7 +25,7 @@ rootdir="${pkgname}-${pkgver}"
build() {
cd ${rootdir}/
mkdir -p build
- cd build && meson --prefix=/usr .. -Denable_tests=true
+ cd build && meson --prefix=/usr .. -Denable_tests=true -Duser_manual=true -Dmanpage=true
ninja
}