summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 26 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d3ae9b87ac3..a23d9b8cea68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm
- pkgdesc = An highly automated, intuitive, Digital Audio Workstation (DAW)
- pkgver = 0.6.039
+ pkgdesc = a highly automated and intuitive digital audio workstation
+ pkgver = 0.6.175
pkgrel = 1
url = https://www.zrythm.org
arch = x86_64
@@ -13,25 +13,24 @@ pkgbase = zrythm
makedepends = ninja
makedepends = help2man
makedepends = python-sphinx
+ makedepends = ladspa
+ makedepends = lv2
depends = gtk3
- depends = lv2
depends = lilv
depends = libx11
depends = jack
depends = libsndfile
depends = libyaml
- depends = gettext
depends = libsamplerate
depends = alsa-lib
- depends = ladspa
depends = fftw
optdepends = portaudio: portaudio backend
optdepends = qt5-base: for embedding qt5 plugin UIs
conflicts = zrythm-git
- source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.039.tar.xz
- source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.039.tar.xz.asc
+ source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.175.tar.xz
+ source = https://download.savannah.nongnu.org/releases/zrythm/zrythm-0.6.175.tar.xz.asc
validpgpkeys = 48132384AD3DF7D86E254B83022EAE42313D70F3
- sha256sums = c9b04756085ba2158b08e18add99d608159f528f36f580cfadf462e134358288
+ sha256sums = 3899f1c37fdc3c925a51e693bf81afd2e19b6c8d0ff4d9fc52fb392973d224b5
sha256sums = SKIP
pkgname = zrythm
diff --git a/PKGBUILD b/PKGBUILD
index 0d2129e2bb07..2ac5f1cd796a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,39 @@
# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
pkgname=zrythm
-pkgver=0.6.039
+pkgver=0.6.175
pkgrel=1
-pkgdesc='An highly automated, intuitive, Digital Audio Workstation (DAW)'
+pkgdesc='a highly automated and intuitive digital audio workstation'
arch=('x86_64' 'i686')
-url='https://www.zrythm.org'
+url="https://www.zrythm.org"
license=('AGPL3')
-depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
- 'libsndfile' 'libyaml' 'gettext'
- 'libsamplerate' 'alsa-lib'
- 'ladspa' 'fftw')
-makedepends=('python' 'gettext' 'sed'
- 'meson' 'ninja' 'help2man' 'python-sphinx')
+depends=('gtk3' 'lilv' 'libx11' 'jack' 'libsndfile'
+ 'libyaml' 'libsamplerate' 'alsa-lib' 'fftw')
+makedepends=(
+ 'python' 'gettext' 'sed'
+ 'meson' 'ninja' 'help2man' 'python-sphinx'
+ 'ladspa' 'lv2')
optdepends=('portaudio: portaudio backend'
'qt5-base: for embedding qt5 plugin UIs')
conflicts=('zrythm-git')
source=("https://download.savannah.nongnu.org/releases/$pkgname/$pkgname-$pkgver.tar.xz"{,.asc})
-sha256sums=('c9b04756085ba2158b08e18add99d608159f528f36f580cfadf462e134358288'
+sha256sums=('3899f1c37fdc3c925a51e693bf81afd2e19b6c8d0ff4d9fc52fb392973d224b5'
'SKIP')
validpgpkeys=('48132384AD3DF7D86E254B83022EAE42313D70F3')
-rootdir="${pkgname}-${pkgver}"
-
build() {
- cd ${rootdir}/
- mkdir -p build
- cd build && meson --prefix=/usr .. -Denable_tests=true -Duser_manual=true -Dmanpage=true
- ninja
+ cd "$pkgname-$pkgver"
+ meson build --prefix=/usr -Denable_tests=true -Duser_manual=true -Dmanpage=true
+ ninja -C build
}
check() {
- cd ${rootdir}/
- cd build && ninja test
+ cd "$pkgname-$pkgver"
+ ninja -C build test
}
package() {
- cd ${rootdir}/
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- cd build && DESTDIR="${pkgdir}/" ninja install
+ cd "$pkgname-$pkgver"
+ install -vDm 644 AUTHORS CONTRIBUTING.md CHANGELOG.md README.md THANKS TRANSLATORS \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ DESTDIR="${pkgdir}/" ninja -C build install
}