summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90f8e124c521..397c8a675370 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zsa-wally
pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
pkgver = 2.0.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/zsa/wally
arch = i686
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = zsa-wally
depends = gtk3
depends = webkit2gtk
depends = libusb
+ depends = npm
provides = wally
source = https://github.com/zsa/wally/releases/download/2.0.0-linux/wally
source = 50-wally.rules
diff --git a/PKGBUILD b/PKGBUILD
index 870ffbc030aa..148619e45cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=zsa-wally
pkgver=2.0.0
-pkgrel=6
+pkgrel=7
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
license=('MIT')
-depends=('gtk3' 'webkit2gtk' 'libusb')
+depends=('npm' 'gtk3' 'webkit2gtk' 'libusb')
provides=('wally')
source=("https://github.com/zsa/wally/archive/${pkgver}-linux.tar.gz"
"50-wally.rules"
@@ -18,6 +18,8 @@ sha256sums=('9dd7dc0b62e3b8ae15684cb10995a8ff04e285ef0bf1a61069040bd7c5c13683'
build() {
export GOPATH="$srcdir"/gopath
+ export GOBIN="$srcdir"/gopath/bin
+ export PATH=$GOBIN:$PATH
cd "$srcdir/wally-$pkgver-linux"
go get github.com/wailsapp/wails/cmd/wails
wails build