summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD7
3 files changed, 4 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a6456a527b1..6a6d69e8d4aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zsa-wally
pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zsa/wally
arch = i686
arch = x86_64
@@ -10,12 +10,9 @@ pkgbase = zsa-wally
depends = webkit2gtk
depends = libusb
provides = wally
- provides = wally-cli
source = https://github.com/zsa/wally/releases/download/1.1.1-linux/wally
- source = https://github.com/zsa/wally/releases/download/1.1.1-linux/wally-cli
source = 50-wally.rules
sha256sums = ef3c743bb3d15f6f5b01f6cddd189a4761be12175d63e852651dbb6653e21d0f
- sha256sums = b968aeba6f17d0873b26371307179dc02cd360a4cfa74732ab5c814607479d82
sha256sums = SKIP
pkgname = zsa-wally
diff --git a/.gitignore b/.gitignore
index 03fc899ab61a..e955b5114df3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,2 @@
-zsa-wally-*.pkg.tar.xz
+zsa-wally-*.pkg.tar.zst
wally
-wally-cli
diff --git a/PKGBUILD b/PKGBUILD
index 04bf982a3fed..aa622056ff69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,21 @@
pkgname=zsa-wally
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
license=('MIT')
depends=('gtk3' 'webkit2gtk' 'libusb')
-provides=('wally' 'wally-cli')
+provides=('wally')
source=('https://github.com/zsa/wally/releases/download/1.1.1-linux/wally'
- 'https://github.com/zsa/wally/releases/download/1.1.1-linux/wally-cli'
'50-wally.rules'
)
sha256sums=('ef3c743bb3d15f6f5b01f6cddd189a4761be12175d63e852651dbb6653e21d0f'
- 'b968aeba6f17d0873b26371307179dc02cd360a4cfa74732ab5c814607479d82'
'SKIP'
)
package() {
install -Dm644 50-wally.rules "$pkgdir"/etc/udev/rules.d/50-wally.rules
install -Dm755 wally "$pkgdir"/usr/bin/wally
- install -Dm755 wally-cli "$pkgdir"/usr/bin/wally-cli
}