summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore2
-rw-r--r--50-wally.rules10
-rw-r--r--PKGBUILD23
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..becbb8a66644
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = zsa-wally
+ pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/zsa/wally
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = webkit2gtk
+ depends = libusb
+ provides = wally
+ provides = wally-cli
+ source = https://github.com/zsa/wally/releases/download/1.0.0/wally-linux.zip
+ source = 50-wally.rules
+ sha256sums = 3aabb326f8a25537042be1a7c7e79dd462a51ae7d8c3060d209d8132c96f555e
+ sha256sums = SKIP
+
+pkgname = zsa-wally
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43c5e9277766
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+zsa-wally-*.pkg.tar.xz
+wally-linux.zip
diff --git a/50-wally.rules b/50-wally.rules
new file mode 100644
index 000000000000..d4f6389278e7
--- /dev/null
+++ b/50-wally.rules
@@ -0,0 +1,10 @@
+# Teensy rules for the Ergodox EZ Original / Shine / Glow
+ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+
+# STM32 rules for the Planck EZ Standard / Glow
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", \
+ MODE:="0666", \
+ SYMLINK+="stm32_dfu"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9271d42a3ed4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jiří Prokop <jprokop@synaptiko.cz>
+
+pkgname=zsa-wally
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
+arch=('i686' 'x86_64')
+url="https://github.com/zsa/wally"
+license=('MIT')
+depends=('gtk3' 'webkit2gtk' 'libusb')
+provides=('wally' 'wally-cli')
+source=('https://github.com/zsa/wally/releases/download/1.0.0/wally-linux.zip'
+ '50-wally.rules'
+)
+sha256sums=('3aabb326f8a25537042be1a7c7e79dd462a51ae7d8c3060d209d8132c96f555e'
+ 'SKIP'
+)
+
+package() {
+ install -Dm644 50-wally.rules "$pkgdir"/etc/udev/rules.d/50-wally.rules
+ install -Dm755 wally "$pkgdir"/usr/bin/wally
+ install -Dm755 wally-cli "$pkgdir"/usr/bin/wally-cli
+}