summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD44
3 files changed, 28 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0a4f9f72708..6d0221582025 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,16 @@
pkgbase = zsa-wally-bin
- pkgdesc = Flash your ZSA Keyboard the EZ way.
+ pkgdesc = Flash your ZSA Keyboard the EZ way
pkgver = 2.1.3
pkgrel = 1
url = https://github.com/zsa/wally
- arch = i686
arch = x86_64
license = MIT
- depends = gtk3
- depends = webkit2gtk
depends = libusb
- provides = wally
- conflicts = zsa-wally
+ depends = webkit2gtk
+ depends = gtk3
source = https://github.com/zsa/wally/releases/download/2.1.3-linux/wally
- source = https://github.com/zsa/wally/raw/2.1.3-linux/appicon.png
- source = https://github.com/zsa/wally/raw/2.1.3-linux/license.md
- source = https://github.com/zsa/wally/raw/2.1.3-linux/dist/linux64/50-wally.rules
- source = https://github.com/zsa/wally/raw/2.1.3-linux/dist/linux64/50-oryx.rules
- source = https://github.com/zsa/wally/raw/2.1.3-linux/dist/linux64/wally.desktop
+ source = zsa-wally-bin-2.1.3.tar.gz::https://github.com/zsa/wally/archive/refs/tags/2.1.3-linux.tar.gz
sha256sums = a30c974c2fd544975e48f7f2ac99a21f936fa3e0803afeeb1096826a79afdbde
- sha256sums = 81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857
- sha256sums = d2841d63f4e0bdfda102390ab1ca09136230d22f88538863b24b0c7fc68e548e
- sha256sums = 05d3e9ef60fe6e18f245457a341db9d84b4c8d81b66da1f061405f3b11d9cd58
- sha256sums = 2d33fa2da9e757ac3b66a3a6d4f11e08b541847c26573d917108a306cc6e3998
- sha256sums = 6bd731e8b34dac1995ba9a60312be598d70d7322a7021ef93378c9cb47025d1f
+ sha256sums = 6d0681a422055208bcfbcb20f44503df05e9e8cf66ba2ef7adec6e5fb8e634ee
pkgname = zsa-wally-bin
diff --git a/.gitignore b/.gitignore
index e955b5114df3..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
-zsa-wally-*.pkg.tar.zst
-wally
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 1af4f0e11c1d..ab30e6ecd69b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,27 @@
-# Maintainer: slimb
-
+# Maintainer: Ary Kleinerman <kleinerman at gmail dot com>
pkgname=zsa-wally-bin
pkgver=2.1.3
pkgrel=1
-pkgdesc='Flash your ZSA Keyboard the EZ way.'
-arch=('i686' 'x86_64')
-url='https://github.com/zsa/wally'
-license=('MIT')
-depends=('gtk3' 'webkit2gtk' 'libusb')
-provides=('wally')
-conflicts=('zsa-wally')
+pkgdesc="Flash your ZSA Keyboard the EZ way"
+arch=(x86_64)
+url="https://github.com/zsa/wally"
+license=(MIT)
+depends=(libusb webkit2gtk gtk3)
source=("https://github.com/zsa/wally/releases/download/${pkgver}-linux/wally"
- "https://github.com/zsa/wally/raw/${pkgver}-linux/appicon.png"
- "https://github.com/zsa/wally/raw/${pkgver}-linux/license.md"
- "https://github.com/zsa/wally/raw/${pkgver}-linux/dist/linux64/50-wally.rules"
- "https://github.com/zsa/wally/raw/${pkgver}-linux/dist/linux64/50-oryx.rules"
- "https://github.com/zsa/wally/raw/${pkgver}-linux/dist/linux64/wally.desktop")
-
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/zsa/wally/archive/refs/tags/${pkgver}-linux.tar.gz")
+provides=()
+conflicts=()
sha256sums=('a30c974c2fd544975e48f7f2ac99a21f936fa3e0803afeeb1096826a79afdbde'
- '81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857'
- 'd2841d63f4e0bdfda102390ab1ca09136230d22f88538863b24b0c7fc68e548e'
- '05d3e9ef60fe6e18f245457a341db9d84b4c8d81b66da1f061405f3b11d9cd58'
- '2d33fa2da9e757ac3b66a3a6d4f11e08b541847c26573d917108a306cc6e3998'
- '6bd731e8b34dac1995ba9a60312be598d70d7322a7021ef93378c9cb47025d1f')
+ '6d0681a422055208bcfbcb20f44503df05e9e8cf66ba2ef7adec6e5fb8e634ee')
+
+prepare() {
+ chmod +x "${srcdir}/wally"
+}
package() {
- install -Dm755 wally "$pkgdir/usr/bin/wally"
- install -Dm644 -t "$pkgdir/usr/lib/udev/rules.d/" 50-oryx.rules 50-wally.rules
- install -Dm644 wally.desktop "$pkgdir/usr/share/applications/wally.desktop"
- install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
- install -Dm644 license.md "$pkgdir/usr/share/licenses/$pkgname/license.md"
+ install -Dm 755 "${srcdir}/wally" "${pkgdir}/usr/bin/wally"
+ install -Dm 644 "${srcdir}/wally-${pkgver}-linux/dist/linux64/"*.rules -t "${pkgdir}/usr/lib/udev/rules.d/"
+ install -Dm 644 "${srcdir}/wally-${pkgver}-linux/dist/linux64/"*.desktop -t "${pkgdir}/usr/share/applications/"
+ install -Dm 644 "${srcdir}/wally-${pkgver}-linux/appicon.png" "${pkgdir}/usr/share/pixmaps/wally.png"
+ install -Dm 644 "${srcdir}/wally-${pkgver}-linux/license.md" "${pkgdir}/usr/share/licenses/${pkgname}/license.md"
}