summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
-rw-r--r--zsh-extract-git.install9
3 files changed, 37 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e8cb637ffa9..aab1462b64a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = zsh-extract-git
- pkgdesc = This plugin defines a function called extract that extracts the archive file you pass it, and it supports a wide variety of archive filetypes.
- pkgver = r2.85ee9a2
+ pkgdesc = This plugin defines a function called extract, it extracts the archive file you pass to it and it supports a wide variety of archive filetypes.
+ pkgver = r7156.06753e814
pkgrel = 1
- url = https://github.com/le0me55i/zsh-extract
+ url = https://github.com/ohmyzsh/ohmyzsh/tree/master/plugins/extract
install = zsh-extract-git.install
arch = any
- license = custom:MIT
+ license = unknown
makedepends = git
depends = zsh
- provides = zsh-extract
- conflicts = zsh-extract
- source = zsh-extract::git://github.com/le0me55i/zsh-extract
+ source = git+https://github.com/ohmyzsh/ohmyzsh.git
+ sha256sums = SKIP
pkgname = zsh-extract-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 544d59b45c38..56515cdbc06e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
-# Maintainer: Andrii Burkivskyi <buryk212@gmail.com>
-_gitname='zsh-extract'
-pkgname="${_gitname}-git"
-pkgver=r2.85ee9a2
+# Maintainer: espritlibre <email@address.invalid>"
+_pkgname=zsh-extract
+pkgname=zsh-extract-git
+pkgver=r7156.06753e814
pkgrel=1
-pkgdesc="This plugin defines a function called extract that extracts the archive file you pass it, and it supports a wide variety of archive filetypes."
-arch=('any')
-url="https://github.com/le0me55i/zsh-extract"
-license=(custom:MIT)
-depends=('zsh')
-makedepends=('git')
-provides=('zsh-extract')
-conflicts=('zsh-extract')
-source=("${_gitname}::${url//https/git}")
-install=zsh-extract-git.install
-sha256sum=('SKIP')
+pkgdesc="This plugin defines a function called "extract", it extracts the archive file you pass to it and it supports a wide variety of archive filetypes."
+arch=(any)
+url="https://github.com/ohmyzsh/ohmyzsh/tree/master/plugins/extract"
+license=('unknown')
+depends=("zsh")
+makedepends=("git")
+install="${pkgname}.install"
+source=(git+https://github.com/ohmyzsh/ohmyzsh.git)
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/ohmyzsh/plugins/extract/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/${_gitname}"
-
- install -Dm644 extract.plugin.zsh "${pkgdir}/usr/share/zsh/plugins/${_gitname}/extract.plugin.zsh"
- install -Dm644 _extract "${pkgdir}/usr/share/zsh/site-functions/_extract"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${_gitname}/README.md"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/extract/_extract" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/extract/extract.plugin.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/extract/README.md" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
}
+
diff --git a/zsh-extract-git.install b/zsh-extract-git.install
index 7ed67f7b6ce1..db991c88ce5e 100644
--- a/zsh-extract-git.install
+++ b/zsh-extract-git.install
@@ -1,7 +1,6 @@
post_install() {
- cat<<<"
-To use, source the library from your .zshrc:
-
- source /usr/share/zsh/plugins/zsh-extract/extract.plugin.zsh
-"
+ cat << EOF
+To activate this plugin, add the following line to your sources section in your ~/.zshrc:
+ source /usr/share/zsh/plugins/zsh-extract/extract.plugin.zsh
+EOF
}