summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec36ed76324f..5e8cb637ffa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = zsh-extract-git
depends = zsh
provides = zsh-extract
conflicts = zsh-extract
- source = git://github.com/le0me55i/zsh-extract
+ source = zsh-extract::git://github.com/le0me55i/zsh-extract
pkgname = zsh-extract-git
diff --git a/PKGBUILD b/PKGBUILD
index 31603ad70ec7..544d59b45c38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
# Maintainer: Andrii Burkivskyi <buryk212@gmail.com>
-pkgname=zsh-extract-git
-_gitname=zsh-extract
+_gitname='zsh-extract'
+pkgname="${_gitname}-git"
pkgver=r2.85ee9a2
pkgrel=1
pkgdesc="This plugin defines a function called extract that extracts the archive file you pass it, and it supports a wide variety of archive filetypes."
-arch=(any)
-url='https://github.com/le0me55i/zsh-extract'
+arch=('any')
+url="https://github.com/le0me55i/zsh-extract"
license=(custom:MIT)
-depends=(zsh)
-makedepends=(git)
-provides=(zsh-extract)
-conflicts=(zsh-extract)
-source=('git://github.com/le0me55i/zsh-extract')
+depends=('zsh')
+makedepends=('git')
+provides=('zsh-extract')
+conflicts=('zsh-extract')
+source=("${_gitname}::${url//https/git}")
install=zsh-extract-git.install
sha256sum=('SKIP')
pkgver() {
- cd "$_gitname"
- commit=$(git rev-list --count master)
- hash=$(git rev-parse --short HEAD)
- echo "r$commit.$hash"
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$_gitname"
+ cd "${srcdir}/${_gitname}"
- install -Dm644 extract.plugin.zsh "$pkgdir"/usr/share/zsh/plugins/"$_gitname"/extract.plugin.zsh
- install -Dm644 _extract "$pkgdir"/usr/share/zsh/site-functions/_extract
- install -Dm644 README.md "$pkgdir"/usr/share/doc/"$_gitname"/README.md
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm644 extract.plugin.zsh "${pkgdir}/usr/share/zsh/plugins/${_gitname}/extract.plugin.zsh"
+ install -Dm644 _extract "${pkgdir}/usr/share/zsh/site-functions/_extract"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${_gitname}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}