summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD2
-rw-r--r--zsh-plugin-wd.install14
4 files changed, 19 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bd3b5507723..698e66016304 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = zsh-plugin-wd
pkgver = 0.5.1
pkgrel = 1
url = https://github.com/mfaerevaag/wd
+ install = zsh-plugin-wd.install
arch = x86_64
license = MIT
depends = zsh
diff --git a/.gitignore b/.gitignore
index 62d30f9218cb..ddbd86619bb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
src/
pkg/
+wd
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 84807ea358c4..3b769b734187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,8 @@ source=(
)
sha256sums=("1b89eba72840c17fdc42899f2269a25a442c56baad6f13b44278f866806a475f")
+install=$pkgname.install
+
prepare() {
mkdir -p $pkgdir/usr/share/$_pkgname $pkgdir/usr/share/man/man1 $pkgdir/usr/share/licenses/$pkgname $pkgdir/usr/share/zsh/site-functions
}
diff --git a/zsh-plugin-wd.install b/zsh-plugin-wd.install
new file mode 100644
index 000000000000..55b2fcef127a
--- /dev/null
+++ b/zsh-plugin-wd.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo 'To enable wd, add the following to your .zshrc file:'
+ echo
+ echo 'wd() {'
+ echo ' . /usr/share/wd/wd.sh'
+ echo '}'
+ echo
+}
+
+post_remove() {
+ echo
+ echo 'Remember to remove wd from your .zshrc file.'
+ echo
+}