summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
-rw-r--r--zsh-plugin-wd-git.install14
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d55613536f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Feb 13 20:17:52 UTC 2017
+pkgbase = zsh-plugin-wd-git
+ pkgdesc = Jump to custom directories in zsh
+ pkgver = v0.4.0.r38.f859a5c
+ pkgrel = 1
+ url = https://github.com/mfaerevaag/wd
+ install = zsh-plugin-wd-git.install
+ arch = any
+ license = custom:MIT
+ makedepends = git
+ depends = zsh
+ provides = zsh-plugin-wd
+ conflicts = zsh-plugin-wd
+ source = git+https://github.com/mfaerevaag/wd
+ md5sums = SKIP
+
+pkgname = zsh-plugin-wd-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2a1dbad925fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/wd
+/zsh-plugin-wd-git-v0.4.0.r38.f859a5c-1-any.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f803d22e54ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sindre Moen <sindrenm at gmail dot com>
+
+pkgname=zsh-plugin-wd-git
+pkgver=v0.4.0.r38.f859a5c
+pkgrel=1
+pkgdesc="Jump to custom directories in zsh"
+arch=('any')
+url="https://github.com/mfaerevaag/wd"
+license=('custom:MIT')
+groups=()
+depends=('zsh')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=$pkgname.install
+source=('git+https://github.com/mfaerevaag/wd')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/wd
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ SRC=$srcdir/wd
+ SHARE=$pkgdir/usr/share/wd
+ MAN=$pkgdir/usr/share/man/man1
+ LICENSES=$pkgdir/usr/share/licenses/$pkgname
+ COMPDEFS=$pkgdir/usr/share/zsh/site-functions
+
+ mkdir -p $SHARE
+ mkdir -p $MAN
+ mkdir -p $LICENSES
+ mkdir -p $COMPDEFS
+
+ cd $SRC
+
+ gzip -f wd.1
+
+ cp wd.sh $SHARE
+ cp wd.1.gz $MAN
+ cp LICENSE $LICENSES
+ cp _wd.sh $COMPDEFS/_wd
+}
diff --git a/zsh-plugin-wd-git.install b/zsh-plugin-wd-git.install
new file mode 100644
index 000000000000..55b2fcef127a
--- /dev/null
+++ b/zsh-plugin-wd-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo 'To enable wd, add the following to your .zshrc file:'
+ echo
+ echo 'wd() {'
+ echo ' . /usr/share/wd/wd.sh'
+ echo '}'
+ echo
+}
+
+post_remove() {
+ echo
+ echo 'Remember to remove wd from your .zshrc file.'
+ echo
+}