summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 368332e2a371..6b8c5310191c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = zur-git
pkgdesc = An AUR helper written in Zig
- pkgver = 0.5
+ pkgver = 0.5.0+3+g49035b5
pkgrel = 1
url = https://github.com/hspak/zur
arch = x86_64
license = MIT
makedepends = zig-git
+ makedepends = git
depends = pacman
depends = curl
provides = zur-git
conflicts = zur-git
- source = git://github.com/hspak/zur
+ source = git+https://github.com/hspak/zur
sha256sums = SKIP
pkgname = zur-git
diff --git a/PKGBUILD b/PKGBUILD
index 22e9cf18b8ef..3d0cee1bca5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hong Shick Pak <hong@hspak.com>
pkgname=zur-git
-pkgver=0.5
+pkgver=0.5.0+3+g49035b5
pkgrel=1
pkgdesc="An AUR helper written in Zig"
arch=("x86_64")
@@ -14,6 +14,11 @@ conflicts=("$pkgname")
source=("git+https://github.com/hspak/zur")
sha256sums=("SKIP")
+pkgver() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
cd "$(echo $pkgname | cut -d'-' -f1)"
zig build -Dversion="${pkgver}" -Drelease-safe=true