summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..368332e2a371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = zur-git
+ pkgdesc = An AUR helper written in Zig
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/hspak/zur
+ arch = x86_64
+ license = MIT
+ makedepends = zig-git
+ depends = pacman
+ depends = curl
+ provides = zur-git
+ conflicts = zur-git
+ source = git://github.com/hspak/zur
+ sha256sums = SKIP
+
+pkgname = zur-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22e9cf18b8ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Hong Shick Pak <hong@hspak.com>
+
+pkgname=zur-git
+pkgver=0.5
+pkgrel=1
+pkgdesc="An AUR helper written in Zig"
+arch=("x86_64")
+url="https://github.com/hspak/zur"
+license=("MIT")
+depends=("pacman" "curl")
+makedepends=("zig-git" "git")
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("git+https://github.com/hspak/zur")
+sha256sums=("SKIP")
+
+build() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ zig build -Dversion="${pkgver}" -Drelease-safe=true
+}
+
+check() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ zig-cache/bin/zur --version
+}
+
+package() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ install -D -m 0755 "zig-cache/bin/zur" "${pkgdir}/usr/bin/zur"
+ install -D -m 0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh syn=sh et