summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a19bd09a75bb..a2aa64d6d3a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zx
pkgdesc = A tool for writing better scripts
- pkgver = 2.1.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/google/zx
arch = any
@@ -8,7 +8,7 @@ pkgbase = zx
makedepends = npm
makedepends = git
depends = nodejs
- source = git+https://github.com/google/zx#commit=ef80b844c74525219536071bab0fd5a6d19bb345
- sha512sums = SKIP
+ source = https://github.com/google/zx/archive/3.0.0.tar.gz
+ sha512sums = e07c6e48b51d156ea504f9ad09af8592c315cfd1b9e70b0f3dc2a01b28677b64e14611dc2ec3ba4eccc8f1f6ef95865d075e49132dd7355747d07922fa4cdc51
pkgname = zx
diff --git a/PKGBUILD b/PKGBUILD
index 171130b5c180..12860cd67881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
pkgname=zx
-pkgver=2.1.0
-_commit=ef80b844c74525219536071bab0fd5a6d19bb345
+pkgver=3.0.0
pkgrel=1
-pkgdesc="A tool for writing better scripts"
-arch=("any")
-url="https://github.com/google/zx"
-license=("Apache")
-depends=("nodejs")
-makedepends=("npm" "git")
-source=("git+${url}#commit=${_commit}")
-sha512sums=("SKIP")
+pkgdesc='A tool for writing better scripts'
+arch=(any)
+url=https://github.com/google/zx
+license=(Apache)
+depends=(nodejs)
+makedepends=(npm git)
+source=("$url/archive/$pkgver.tar.gz")
+sha512sums=('e07c6e48b51d156ea504f9ad09af8592c315cfd1b9e70b0f3dc2a01b28677b64e14611dc2ec3ba4eccc8f1f6ef95865d075e49132dd7355747d07922fa4cdc51')
build() {
- cd ${pkgname}
+ cd "$pkgname-$pkgver"
npm install --production
}
package() {
- cd ${pkgname}
+ cd "$pkgname-$pkgver"
- local _npmdir="${pkgdir}/usr/lib/node_modules"
- install -d "${_npmdir}/${pkgname}"
- cp -r * "${_npmdir}/${pkgname}"
+ local _npmdir="$pkgdir/usr/lib/node_modules"
+ install -d "$_npmdir/$pkgname"
+ cp -r * "$_npmdir/$pkgname"
- local _bindir="${pkgdir}/usr/bin"
- mkdir -p "${_bindir}"
- ln -s "/usr/lib/node_modules/${pkgname}/zx.mjs" "${_bindir}/zx"
+ local _bindir="$pkgdir/usr/bin"
+ mkdir -p "$_bindir"
+ ln -s "/usr/lib/node_modules/$pkgname/zx.mjs" "$_bindir/zx"
- install -Dm644 LICENSE "${pkgdir}/usr/share/license/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/license/$pkgname/LICENSE"
}
# vim: syntax=sh