summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--mruby-dir-glob.patch12
-rw-r--r--mruby.patch45
4 files changed, 72 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 840a30fe4b2a..601e91ddc22d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,13 +28,16 @@ pkgbase = zyn-fusion
source = BashCompletion.cmake
source = gcc10.patch
source = file-picker.patch
+ source = mruby.patch
+ source = mruby-dir-glob.patch
source = parameter-ranges.patch
b2sums = SKIP
b2sums = SKIP
b2sums = 14be130e88c2e1d2b8312ca9f6d426834a26360594ed9ed22222a98603e1d5a51e86450911c76563545f55a80952c7dfb05a251e36d59684527caccdf976c474
b2sums = 1f41e7a0a50f1f11a4853bd8d8daea5f4510b567381768a8bc61e15082aa668f924e3d6787cbb93a16eee2da2a34a5d20f18e69399718166d6b9d3f47b648987
b2sums = d99df6908b1af24d018726b6b737f13cbcd153deb5667e03ea3e138f22c83c237f70921dec58e739486acb3a488965858cb60ab140e00e30f6fb80833af1401d
+ b2sums = 2b2c9523cea9fe5063355e831ed154ffc82cfded3afac28f5f7fda4c392a152fc859af875b51a1ce763a877676d1573d74eaa11c713d8d61c78ebb7740e51544
+ b2sums = 23a20e603b6da0fc65665e83669d4b4ec784b2c3a4fa1edead2003c7ee8a1b7b5d13655ecb6fcb3f430d36fd0074ba68c2e5fa4a3aba07e06b1c2ae077090795
b2sums = f53c8142a3f3a77d37348537e8ac36be36b0003d5bf0d5214fb4ca9cece253d25d57d9bdddd19c4545671a03ea499365ef629a461582fd3d24c8b174b5c45f29
pkgname = zyn-fusion
-
diff --git a/PKGBUILD b/PKGBUILD
index f1c10ed12a39..21dbb64a6ab6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,12 +18,16 @@ source=("git+https://github.com/zynaddsubfx/zynaddsubfx.git#tag=$pkgver"
'BashCompletion.cmake'
'gcc10.patch'
'file-picker.patch'
+ 'mruby.patch'
+ 'mruby-dir-glob.patch'
'parameter-ranges.patch')
b2sums=('SKIP'
'SKIP'
'14be130e88c2e1d2b8312ca9f6d426834a26360594ed9ed22222a98603e1d5a51e86450911c76563545f55a80952c7dfb05a251e36d59684527caccdf976c474'
'1f41e7a0a50f1f11a4853bd8d8daea5f4510b567381768a8bc61e15082aa668f924e3d6787cbb93a16eee2da2a34a5d20f18e69399718166d6b9d3f47b648987'
'd99df6908b1af24d018726b6b737f13cbcd153deb5667e03ea3e138f22c83c237f70921dec58e739486acb3a488965858cb60ab140e00e30f6fb80833af1401d'
+ '2b2c9523cea9fe5063355e831ed154ffc82cfded3afac28f5f7fda4c392a152fc859af875b51a1ce763a877676d1573d74eaa11c713d8d61c78ebb7740e51544'
+ '23a20e603b6da0fc65665e83669d4b4ec784b2c3a4fa1edead2003c7ee8a1b7b5d13655ecb6fcb3f430d36fd0074ba68c2e5fa4a3aba07e06b1c2ae077090795'
'f53c8142a3f3a77d37348537e8ac36be36b0003d5bf0d5214fb4ca9cece253d25d57d9bdddd19c4545671a03ea499365ef629a461582fd3d24c8b174b5c45f29')
prepare() {
@@ -38,6 +42,13 @@ prepare() {
cd ../mruby-zest-build
git submodule update --init
git apply -3 "$srcdir"/gcc10.patch
+ pushd mruby
+ git apply -3 "$srcdir"/mruby.patch
+ popd
+ pushd deps/mruby-dir-glob
+ git apply -3 "$srcdir"/mruby-dir-glob.patch
+ popd
+
make setup
}
diff --git a/mruby-dir-glob.patch b/mruby-dir-glob.patch
new file mode 100644
index 000000000000..1ea4260fc2ce
--- /dev/null
+++ b/mruby-dir-glob.patch
@@ -0,0 +1,12 @@
+diff --git a/mrbgem.rake b/mrbgem.rake
+index e7481ab..8cba5e1 100644
+--- a/mrbgem.rake
++++ b/mrbgem.rake
+@@ -10,7 +10,6 @@ MRuby::Gem::Specification.new('mruby-dir-glob') do |spec|
+ spec.add_dependency 'mruby-errno'
+ spec.add_dependency 'mruby-file-stat'
+ spec.add_dependency 'mruby-process'
+- spec.add_dependency 'mruby-pack'
+
+ # how to specify a 'general' regexp engine?
+ # spec.add_dependency 'mruby-regexp-pcre'
diff --git a/mruby.patch b/mruby.patch
new file mode 100644
index 000000000000..50df662c510c
--- /dev/null
+++ b/mruby.patch
@@ -0,0 +1,45 @@
+diff --git a/Rakefile b/Rakefile
+index dd14c8b0..193cf28d 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -35,15 +35,15 @@ load "#{MRUBY_ROOT}/tasks/gitlab.rake"
+ task :default => :all
+
+ bin_path = ENV['INSTALL_DIR'] || "#{MRUBY_ROOT}/bin"
+-FileUtils.mkdir_p bin_path, { :verbose => $verbose }
++FileUtils.mkdir_p bin_path
+
+ depfiles = MRuby.targets['host'].bins.map do |bin|
+ install_path = MRuby.targets['host'].exefile("#{bin_path}/#{bin}")
+ source_path = MRuby.targets['host'].exefile("#{MRuby.targets['host'].build_dir}/bin/#{bin}")
+
+ file install_path => source_path do |t|
+- FileUtils.rm_f t.name, { :verbose => $verbose }
+- FileUtils.cp t.prerequisites.first, t.name, { :verbose => $verbose }
++ FileUtils.rm_f t.name
++ FileUtils.cp t.prerequisites.first, t.name
+ end
+
+ install_path
+@@ -76,8 +76,8 @@ MRuby.each_target do |target|
+ install_path = MRuby.targets['host'].exefile("#{bin_path}/#{bin}")
+
+ file install_path => exec do |t|
+- FileUtils.rm_f t.name, { :verbose => $verbose }
+- FileUtils.cp t.prerequisites.first, t.name, { :verbose => $verbose }
++ FileUtils.rm_f t.name
++ FileUtils.cp t.prerequisites.first, t.name
+ end
+ depfiles += [ install_path ]
+ elsif target == MRuby.targets['host-debug']
+@@ -85,8 +85,8 @@ MRuby.each_target do |target|
+ install_path = MRuby.targets['host-debug'].exefile("#{bin_path}/#{bin}")
+
+ file install_path => exec do |t|
+- FileUtils.rm_f t.name, { :verbose => $verbose }
+- FileUtils.cp t.prerequisites.first, t.name, { :verbose => $verbose }
++ FileUtils.rm_f t.name
++ FileUtils.cp t.prerequisites.first, t.name
+ end
+ depfiles += [ install_path ]
+ end