summarylogtreecommitdiffstats
path: root/CMake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'CMake.patch')
-rw-r--r--CMake.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/CMake.patch b/CMake.patch
new file mode 100644
index 000000000000..3d231571537e
--- /dev/null
+++ b/CMake.patch
@@ -0,0 +1,27 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c29d9bf..4957d6d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,10 +1,16 @@
+ cmake_minimum_required(VERSION 2.6)
++project(SOIL)
++
++if(NOT CMAKE_BUILD_TYPE)
++ set(CMAKE_BUILD_TYPE Release)
++endif()
+
+ include_directories(inc)
+
+-ADD_LIBRARY( soil STATIC
+- src/image_helper.c
+- src/stb_image_aug.c
+- src/image_DXT.c
+- src/SOIL.c
+- )
++FILE(GLOB SOIL_c src/*.c)
++FILE(GLOB SOIL_h inc/SOIL/*.h)
++
++ADD_LIBRARY( soil STATIC ${SOIL_c} )
++SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "Installation root directory" FORCE)
++install( TARGETS soil ARCHIVE DESTINATION "lib" )
++install( FILES ${SOIL_h} DESTINATION "include/SOIL" )