summarylogtreecommitdiffstats
path: root/CMakeLists.txt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt.patch')
-rw-r--r--CMakeLists.txt.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
new file mode 100644
index 000000000000..678a41147f7c
--- /dev/null
+++ b/CMakeLists.txt.patch
@@ -0,0 +1,28 @@
+--- lsyncd-release-2.1.6/CMakeLists.txt 2015-10-15 08:29:47.000000000 +0200
++++ ../lsyncd-release-2.1.6/CMakeLists.txt 2016-02-11 12:57:52.894941796 +0100
+@@ -54,7 +54,7 @@
+ # this supposes the Lua compiler 'luac' is sitting right next to the Lua interpreter 'lua'
+ add_custom_command( OUTPUT runner.out
+ COMMAND ${CMAKE_COMMAND} -E echo "Compiling built-in runner"
+- COMMAND ${LUA_EXECUTABLE}c -o runner.out ${PROJECT_SOURCE_DIR}/lsyncd.lua
++ COMMAND ${LUA_COMPILER} -o runner.out ${PROJECT_SOURCE_DIR}/lsyncd.lua
+ DEPENDS ${PROJECT_SOURCE_DIR}/lsyncd.lua
+ )
+
+@@ -75,14 +75,14 @@
+
+ add_custom_command( OUTPUT defaults.out
+ COMMAND ${CMAKE_COMMAND} -E echo "Compiling built-in default configs"
+- COMMAND ${LUA_EXECUTABLE}c -o defaults.out ${DEFAULT_CONFIGS}
++ COMMAND ${LUA_COMPILER} -o defaults.out ${DEFAULT_CONFIGS}
+ DEPENDS ${DEFAULT_CONFIGS}
+ )
+
+ # the manpage
+ add_custom_command( OUTPUT doc/lsyncd.1
+ COMMAND ${CMAKE_COMMAND} -E echo "Updating the manpage"
+- COMMAND a2x --format=manpage doc/lsyncd.1.txt
++ COMMAND a2x --format=manpage ${PROJECT_SOURCE_DIR}/doc/lsyncd.1.txt
+ DEPENDS doc/lsyncd.1.txt
+ )
+ add_custom_target( manpage ALL DEPENDS doc/lsyncd.1 )