summarylogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..e75b540c02de
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 2.6)
+
+project(TinyXml)
+
+
+include_directories(./)
+
+file(
+ GLOB_RECURSE
+ source_files
+ *.h
+ tiny*.cpp
+)
+
+add_library(tinyxml ${source_files}
+)
+
+#SET_TARGET_PROPERTIES (tinyxml PROPERTIES DEFINE_SYMBOL "EXPORT" )
+
+INSTALL( FILES tinyxml.h tinystr.h DESTINATION include )
+
+INSTALL( TARGETS tinyxml RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX} ) \ No newline at end of file