summarylogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..cd270702b8c5
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 3.23)
+project(rocm-core)
+add_library(rocm-core SHARED rocm_version.c)
+set_target_properties(rocm-core PROPERTIES VERSION "1.0.${ROCM_VERSION}")
+find_path(ROCM_HEADER_DIR rocm_version.h)
+target_include_directories(rocm-core PUBLIC ${ROCM_HEADER_DIR})
+install(TARGETS rocm-core LIBRARY DESTINATION lib)