summarylogtreecommitdiffstats
path: root/Makefile.LINUX
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.LINUX')
-rw-r--r--Makefile.LINUX51
1 files changed, 51 insertions, 0 deletions
diff --git a/Makefile.LINUX b/Makefile.LINUX
new file mode 100644
index 000000000000..0f5d624194ae
--- /dev/null
+++ b/Makefile.LINUX
@@ -0,0 +1,51 @@
+#
+# Makefile.LINUX
+#
+#
+# If you compile, change the name to Makefile.in.
+#
+#
+
+#-----------------------------------------------------------------------------
+# Shell
+#-----------------------------------------------------------------------------
+
+SHELL = /bin/sh
+
+#-----------------------------------------------------------------------------
+# Platform
+#-----------------------------------------------------------------------------
+
+PLAT = LINUX
+
+#-----------------------------------------------------------------------------
+# Libraries and includs
+#-----------------------------------------------------------------------------
+
+BLLIB = libblas.a
+CBDIR = $(HOME)/CBLAS
+CBLIBDIR = $(CBDIR)/lib/$(PLAT)
+CBLIB = $(CBLIBDIR)/cblas_$(PLAT).a
+
+#-----------------------------------------------------------------------------
+# Compilers
+#-----------------------------------------------------------------------------
+
+CC = gcc
+FC = gfortran
+LOADER = $(FC)
+
+#-----------------------------------------------------------------------------
+# Flags for Compilers
+#-----------------------------------------------------------------------------
+
+CFLAGS = -O3 -DADD_ -fPIC
+FFLAGS = -O3 -fPIC
+
+#-----------------------------------------------------------------------------
+# Archive programs and flags
+#-----------------------------------------------------------------------------
+
+ARCH = ar
+ARCHFLAGS = r
+RANLIB = echo