summarylogtreecommitdiffstats
path: root/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.inc')
-rw-r--r--Makefile.inc18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile.inc b/Makefile.inc
index 1ddb1af4a015..a17c9289c14b 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -41,7 +41,7 @@
#
SCOTCHDIR = /usr
-ISCOTCH = -I$(SCOTCHDIR)/include/scotch
+ISCOTCH = -I$(SCOTCHDIR)/include
#
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
@@ -58,7 +58,7 @@ IPORD = -I$(topdir)/PORD/include/
LPORD = -L$(LPORDDIR) -lpord
LMETISDIR = /usr/lib
-IMETIS = -I/usr/include/metis
+IMETIS = -I/usr/include
# You have to choose one among the following two lines depending on
# the type of analysis you want to perform. If you want to perform only
@@ -91,7 +91,7 @@ IORDERINGSC = $(IMETIS) $(IPORD) $(ISCOTCH)
PLAT =
# Library extension, + C and Fortran "-o" option
# may be different under Windows
-LIBEXT = .a
+LIBEXT = .so
OUTC = -o
OUTF = -o
# RM : remove files
@@ -104,11 +104,11 @@ FC = mpif90
FL = mpif90
# AR : Archive object in a library
# keep a space at the end if options have to be separated from lib name
-AR = ar vr
+AR = $(CC) -shared $(OPTC) -o
# RANLIB : generate index of an archive file
# (optionnal use "RANLIB = echo" in case of problem)
-RANLIB = ranlib
-#RANLIB = echo
+# RANLIB = ranlib
+RANLIB = echo
# DEFINE HERE YOUR LAPACK LIBRARY
@@ -150,7 +150,7 @@ LIBOTHERS = -lpthread
CDEFS = -DAdd_
#COMPILER OPTIONS
-OPTF = -DALLOW_NON_INIT ${CFLAGS} -fPIC
+OPTF = -DALLOW_NON_INIT ${CFLAGS} -fPIC -fallow-argument-mismatch
OPTC = ${CFLAGS} -fPIC
OPTL = ${CFLAGS} -fPIC
@@ -159,10 +159,10 @@ OPTL = ${CFLAGS} -fPIC
#Sequential:
#INCS = $(INCSEQ)
#LIBS = $(LIBSEQ)
-LIBSEQNEEDED = libseqneeded
+#LIBSEQNEEDED = libseqneeded
#Parallel:
INCS = $(INCPAR)
LIBS = $(LIBPAR)
-#LIBSEQNEEDED =
+LIBSEQNEEDED =