summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index dce79dc2450e..1d3bbead5fed 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,8 @@
-PACKAGE=akku-*-any.pkg.tar.xz
-
+.PHONY: all clean verify force-build update-checksums
-default:
- @make all
+PACKAGE=akku-*-any.pkg.tar.xz
+# default
all: $(PACKAGE)
@make verify
@make .SRCINFO
@@ -13,13 +12,11 @@ clean:
-rm -R src/
-rm -R pkg/
-
# NOTE: excludes are only used to prevent namcap false positives over Guile object (.go) files
verify: PKGBUILD $(PACKAGE)
@namcap PKGBUILD
@namcap --exclude=anyelf,elfgnurelro,elfunstripped,elfnopie $(PACKAGE)
-
# forces a full makepkg build
force-build:
@LC_ALL=C makepkg -f --clean
@@ -29,7 +26,6 @@ update-checksums:
makepkg --verifysource --skipchecksums -f --nobuild --noextract
updpkgsums
-
.SRCINFO: PKGBUILD
@makepkg --printsrcinfo > .SRCINFO