summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..7f52ecd2fce2
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+VERSION:=$(version)
+
+release: update test
+ makepkg --printsrcinfo > .SRCINFO
+ git add .SRCINFO PKGBUILD
+ git commit -m "update to $(VERSION)"
+
+update:
+ sed -i -e "s/^\(pkgver=*\)\(.*\)*/\1$(VERSION)/" PKGBUILD
+ updpkgsums
+
+test:
+ makepkg --verifysource
+
+install:
+ makepkg -sir
+
+clean:
+ rm alfaview_*.deb
+ rm -rf src/
+ rm -rf pkg/