summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 530ee439c38d..b2a6fee7ffa9 100644
--- a/Makefile
+++ b/Makefile
@@ -3,8 +3,23 @@ all: .SRCINFO
.SRCINFO: PKGBUILD
makepkg --printsrcinfo > .SRCINFO
-test:
+test: systemc
+ testing-x86_64-build -c -- -n -I systemc/systemc-*.pkg*
+
+quick-test:
makepkg -sf
namcap archc-git-*.pkg*
-.PHONY: all clean test
+systemc:
+ # Make systemc dependency from AUR
+ if [ ! -f systemc/systemc-*.pkg* ] ; then \
+ rm -rf systemc/ && \
+ wget https://aur.archlinux.org/cgit/aur.git/snapshot/systemc.tar.gz && \
+ tar xf systemc.tar.gz && \
+ cd systemc && makepkg ;\
+ fi
+
+clean:
+ rm -rf ArchC/ pkg/ src/ systemc/ *.log archc-git-*.pkg*
+
+.PHONY: all test quick-test systemc clean