summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..8a02706c1167
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+all: clean build git install
+
+clean:
+ rm -r src pkg || true
+
+geninteg:
+ sed -i '/.*sums=(/,$$d' PKGBUILD
+ makepkg --geninteg >> PKGBUILD
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+makepkg:
+ makepkg -s
+
+build: geninteg srcinfo makepkg
+
+git: git_add git_commit
+
+git_add:
+ git add PKGBUILD .SRCINFO
+
+git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+git_commit:
+ git commit -m "Update to ${VERSION}"
+
+install:
+ makepkg --install