aboutsummarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..30051c8b145d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+all: PKGBUILD .SRCINFO
+
+PKGBUILD:
+ sed -i '/depends=/,/)/d' $@
+ ./build_depends.py >> $@
+ updpkgsums
+ sed -i '/^$$/d' $@ # updpkgsums adds a newline
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+check: PKGBUILD
+ makepkg -fc
+
+clean:
+ $(RM) *.pkg.*
+
+.PHONY: all check clean PKGBUILD