summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cbc2f5ad4e58..2ef4b9cea761 100644
--- a/Makefile
+++ b/Makefile
@@ -37,11 +37,12 @@ package_auto: update_tag ## Auto packaging
clean: ## remove tar.gz
rm -vf *.tar.xz *.tar.gz
-update_tag: LATEST := "$(shell curl -sL https://api.github.com/repos/aws-cloudformation/cloudformation-guard/releases/latest | jq -r '.tag_name|ltrimstr("v")')"
+update_tag: LATEST := $(shell curl -sL https://api.github.com/repos/aws-cloudformation/cloudformation-guard/releases/latest | jq -r '.tag_name|ltrimstr("v")')
update_tag: ## get and update newest version in PKGBUILD
source ./PKGBUILD && \
if [[ $${pkgver} != $(LATEST) ]]; then \
sed -i -e 's/^pkgver=.*$$/pkgver=$(LATEST)/' ./PKGBUILD && \
+ sed -i -e 's/^pkgrel=.*$$/pkgrel=1/' ./PKGBUILD && \
updpkgsums && \
git diff ./PKGBUILD; \
fi