summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..2b5486bd2228
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+.PHONY: all
+
+all: clean srcinfo rebuild
+
+rebuild:
+ makepkg -s
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf pkg src chatterino7/ chatterino2-*.pkg.tar.{xz,zst} \
+ libcommuni \
+ humanize \
+ qBreakpad \
+ WinToast \
+ settings \
+ signals \
+ serialize \
+ rapidjson \
+ qtkeychain \
+ websocketpp