summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 75faaf28d7ad..85071e3e5086 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,26 @@
default: build
-build: clean namcap
+prep: clean namcap
rm -rf Gemfile.lock
bundle install
+ # Fetches latest version info, updates
+ # PKGBUILD, and creates a .commit_msg
bundle exec ruby update.rb
+
+build: prep
makepkg
makepkg --printsrcinfo > .SRCINFO
+# .commit_msg is created by update.rb,
+# if there is a new version.
+commit: .commit_msg
+ echo "Committing: "
+ cat .commit_msg
+ git add .SRCINFO
+ git add PKGBUILD
+ git commit -S -s -F .commit_msg
+ rm .commit_msg
+
clean:
git clean -fd
rm -rf pkg src *.deb *.tar.xz