summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 883364b82894..9e0756c3ef01 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,13 @@
+VERSION := $(shell grep "pkgver=" PKGBUILD | cut -d"=" -f2)
+RELEASE := $(shell grep "pkgrel=" PKGBUILD | cut -d"=" -f2)
+
default:
update:
updpkgsums
makepkg --printsrcinfo > .SRCINFO
+ git add PKGBUILD .SRCINFO
+ git commit -m "release $(VERSION)-$(RELEASE)"
+ git tag "$(VERSION)-$(RELEASE)"
.PHONY: default