summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..1a93fbae713a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+ifeq ($(KERNELRELEASE),)
+KERNELRELEASE=$(shell uname -r)
+endif
+
+obj-m := frandom.o
+
+KDIR := /lib/modules/$(KERNELRELEASE)/build
+PWD := $(shell pwd)
+
+default:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+clean:
+ $(MAKE) -C $(KDIR) M=$(PWD) clean